WH4 remote control — how does the power switch work?

My WH4 remote control suddenly didn’t power-on (power led won’t light up and moving the throttle has no effect) so I opened it up, hoping I could spot something that could be fixed, but it turns out I don’t understand how the power switch is working. Obviously there is a magnet on the slider, and I guess it affects the oblong component on the pcb underneath it. Anyone knows how it works? Any ideas on how to troubleshoot this?

There is a reed switch, I think that is how it works, see here:

You might need to change that reed switch.

1 Like

Bridge the Reed switch with a wire to see if it fires up. Maybe the Lipo is gone. Check the voltage of the battery


Thank you for excellent feedback! After reading up a bit on reed switches I could, with the help of a fluke and a magnet, verify that it worked. It turned out that one of the wires from the battery had really poor connection to the board. I soldered it back and then it worked fine!

However, after reassembling the remote I saw that the power led was flashing without the power switch being on. It soon went black again and now, again, the power switch won’t turn the remote on (ie back to square one). The reed switch seems to still work, but I measure zero volts from the battery, and it seems that charging is not working (the charge led lit up for a short while at first, but now it won’t light up at all).

I’m not sure if I introduced a new fault here or if it’s still the initial problem that shows… Any ideas on how to proceed?

You could confirm if the battery has died by putting the multimeter directly on to the lipo contacts.

Yep, the battery is fully discharged (measured 0.003V after disconnecting it from the board). I’ll see if I can recover it or find a replacement. Thanks!

You can get a new battery from disposable e-cigarette/vape device, 10 bucks or so, get one that has a square shape.

Recovering the battery is very difficult as most chargers will not start charging unless the voltage is within a higher range. I’ve done it before by directly connecting a similar battery and pulsing the connection on and off until the voltage rises but I don’t recommend this.

do not try recover lipos please! These get seriously damaged when deep discharged. It might work, but you also might get stuck 3 miles offshore with dead transmitter.

Turnigy Nano-Tech 600mAh 1S 25C Lipo Pack w/Walkera Plug | HobbyKing

check here you will find cheap replacement. Do not know if this one exactly fits, but check the dimensions and search the website, for sure you wil find something

Thanks a bunch for all input! I could recover the battery with pulse charging, but as @Toto44 is mentioning it is probably a bad idea to use it.

However, there seem to be something wrong with the circuitry — the battery is discharged when the RC is idle (if the RC is switched on for more than a few seconds it can’t be switched off, and the power led eventually flickers and fades to black). After some futile attempts to find the culprit (one suspect was the inductive charging coil, but disconnecting it made no difference) I’m now leaning towards buying a new RC.

Any ideas for rescuing my RC are of course welcome.
If buying a new remote, should I go for the same (WH4) or something else? Reading about Bluemind here on the forum.

Is that supposed to be waterproof? If so, I don’t see how it creates a seal to keep water out?

I’m assuming the circuit board has some sort of conformal coating which is waterproof, all switches and throttle are sealed so reed switch and hall sensor. I have ordered one to see what it like, I will probably double up the the circuit board waterproofing though.

This remote is juste good to testing this have not a clean throtle accel curve so toi don’t want to swim a lot because a remote problem…don’t loose you’re Time and buy a decent remote like Félix remote or mayteck with conformal coating if you don’t have 290 dollars🤙

My Remote just arrived, it looks a little bit different so maybe they fixed some issues. I will test how smooth the signal is and let everyone know.

Oh, does anybody know how the throttle spring is fitted?

I measured the PWM signal and the signal jumps from 1000us to 1100us on the low end and jumps 1900us to 2000us on the high end.

You only get to use the first 2/3 of the throttle movement, above that and the throttle does nothing.

Thats exactly what I measured. Also got the new version.

Also I have the Problem that the throttle goes crazy after some time. Like you put a 4hz sin wave signal on top of the throttle signal. Only happens when I ride some time. Its only when the remote is powered on.

Also the throttle lever has a very big dead zone on the top and bottom. Its like only half of its travel can actually controll something, the rest does nothing. Resulting in extremly sensitive throttle. (you guys also have that problem?)

I found that you could fix this by changing the lever and put the magnet some other way to the hall sensor so it doesn’t make so much travel.
Thinking of putting this electronic in a DIY housing with “pistol trigger” type trottle

1 Like

I dislike this remote very much. Mine one from 2 years ago had glitches throughout the range.

I dumped some epoxy over the whole pcb. The conformal coat it comes with isn’t the best. Glad I ditched it and got the maytech remote… which has other problems but it’s still much better.

you can get yours here free shipping in promotion time, get it while the stock last, https://bit.ly/3VPNEe7

Same for me, bought this remote 2021 from Firduo, it’s total crap.