400a Flier ESC not working anymore

Hey everyone!
So i‘ve just finished building a 2 thruster jet surfboard with 500kv SSS56123 and 400a Fliet 22s ESC on 12S. Tested it on monday and it worked fine (used 50% max throttle). However, after monday one of the esc just seems dead, no beeping when plugging in or anything. Weirdly enough it still works when plugging into the PC, so i tried resetting it like 10 times and reflashing the firmware couple times but nothing seems to work… Does not smell burnt or anything.
Did anyone have a similar issue and has fixed it or generally does anyone know what i should try to do? Would really hope to be on the water as soon as possible again, so don‘t really want to send it to flier directly if there‘s something i can try on my own…
Thanks a lot everyone!

1 Like

I once had this with one of my flier esc’s (ESC 240 / 16S) in my jet board.
All I needed to do was access it with the PC, reset it (default settings), and re set the settings for the motor. (56102 / 600kv)
After this it was working fine again.

Are you using a Y cable to split the signal from the receiver to the ESC’s? If so, swap it and see if this is the problem.

Hey Kian!
Thanks a lot for the response, sounds promising. I‘ve already tried resetting the esc back to default values aswell as reflashing the firmware, but with no success.
However, what do you mean with „re set the motor values“?

re: re set the motor values
Needed to program the ESC with the needed motor values. (disable reverse, motor timing degrees and so on )

where do i know exactly which settings i need? Motor timing just dependent on motor poles and ppm frequency?
Thanks :pray:t3:

Connect everything then run the motor wizard in vesc tools.
It should give you values that should work.

It is a ESC not a VESC :wink:

Oops, my bad :relaxed:

Hi Yseig did you have any luck getting your flier 400a esc working i have the exact same problem

I didn‘t unfortunatly but i‘ve been given a replacement esc for quite cheap. Good customer service from Flier.