6374 FOC problems

I am having problems with the FOC setup my 75100 ESC:

Motor 6374, Flipsky 75100, current VESC firmware, Maytech Remote E Surf.

When the motor was new the setup with VESC was no problem, wizard for motor and remote done, everything ran perfectly.

Now after about 10 successful foil session, I tried another motor and wanted to make the 6374 again. Setup performed again and nothing works. The motor only clacks, ESC gets hot, repeated several times, the wizard runs through, but registers 190A, which is much too high (are otherwise only 60A). Different advanced FOC parameter keeps the motor turning, but not really solved the problem.

Fortunately I have saved the old configuration :slight_smile: So the engine runs again, but has when starting partially also the jerk. On the water I also have the feeling the controller is getting hotter.

I must admit, I have not sealed the engine, only exchanged bearings, always pulled off the bell and rinsed everything with fresh water, then some anticorrusion on it, visually there is less corrosion to see. What do you think is the 6374 at the end?

Thx olli

Definitely corrosion causing shorting between phases.

1 Like