65161 & High-Current-FSESC-200A Troubleshooting help needed

Hi, I was wondering if anyone can help me troubleshoot my setup?
Setup: Flipsky 65161 120kv / Flipsky High-Current-FSESC-200A-60V-ESC / Maytech MTSKR1905WF / 12S (2x 6S 20Ah Lipos)
Problem: Everything was running fine while testing but suddenly stopped working - and I cannot figure out if it is the Motor or the ESC that is broken? Is there an easy way to tell so that I can buy the right replacement part?
Background: Configured using VESC Tool according to the threads here and motor worked fine for several days and many tests and remote displayed all information nicely. Then tested the setup in a water barrel and also worked fine. Charged my battery fully, as well as the remote. Then went to the beach the next day to try it all out live and it did not work.
Symptoms: When pulling the trigger on the remote the motor axle jerks once and then it seems like the remote is disconnected temporarily, like the power to the reciever cuts of. I can see on the remote display that there is a voltage spike just before disconnecting. This disconnect behaviour happens also without pulling the trigger now. When disconnecting the motor the remote disconnect can still happen but much less frequently.

What I tried so far:

  • Checked motor axle - I can spin it freely with my hand - so not stuck
  • Tried setting up motor again via VESC Tool (with and without the remote connected) - when it tries to spin up the motor the same thing happens, it jerks once and then I loose the connection to the VESC Tool (with an error saying lost connection). Having tried this multiple times sometimes I get a “setup completed” without the connection dropping, but the motor doesn’t spin up and the detection results looks strange (Motor R: 1044 mO, Motor L: 1008 uH). Once I even got the motor to make a sound when running experiments (sounded like it was spinning but the axle didn’t actually spin, the motor got quite warm) but cannot repeat that result again.
  • Upgraded VESC firmware to latest version: No change
  • Checked all the cable solderings: Looks fine
  • Measured the motor resistance: All pair combinations measure same ohm
  • Checked remote on a RC car set up: Works fine
  • Used a different remote on VESC: Didn’t help

So any tips on what else I can try to determine what part has broken. Or what can possibly have happened (so this doesn’t happen again).

The only thing I can think of is that the motor took on water during the water barrel test, or that the esc got messed up when connecting the fully charged batteries - but I am stuck for ideas right now…

Very often on the forum the question is whether the motor works. I think any new motor should be tested first to see if it works at all, at least dry (at home on a table), before being plugged into the e-foil system. The same method can be repeated at any later time if unexpected problems arise as above. It is possible to test not only if the motor is turning at all, but also if the motor is quiet (what is the quality of the bearings) and if the motor is not vibrating (if it is well balanced).

It is very easy to dry test the motor in two ways. One is a bit more expensive (comes out to about 10 to 20 Euro), the other is very cheap but very limited. Tomorrow I will try the more expensive method, as I have everything I need at my disposal and I have a new motor (APS63100) that I haven’t tested at all. If the method is successful, I’ll explain it here right away (Saturday at the latest).

1 Like

Hi, yes that is what I am after. A cheap way of testing if the motor works or not (without having to buy another high current esc). Looking forward to your description on how you test this (both the “cheap” and the “expensive” way would be of interest).

@Fred You can Try to switch vesc and motor with your rc car
I did put the correct voltage limit in the vesc ( high and low) ?
Have you try bldc mode ?

If you saved motor configuration in a folder , can you set older detection number R and L … ( happened to me , I enter older detection number to get it work again and then run detection again )

1 Like

Thanks, will try these out and report back. I saved the config files when everything was working fine so can go back to those and double check. Will try powering up a smaller rc car motor with the esc also.