Conformal coating ESC tips - Flipsky 75200


I bought a Flipsky 75200 with an aluminum case. I plan on applying conformal coating to the board.

I have not conformal coated an ESC before, so any tips or advise is welcomed.

  1. One speed bump I am running into is how the boards are stacked. Is there a way to safely separate the boards?
  • do I just desolder the pins on the top PCB?
  1. should conformal coat what’s under the white paste? Or is the presence of the white paste adequate (does not need conformal coating)

There is not much on the botom side.

Noted - I will not apply conformal coating there then

Any tips for conformal coating the lower PCB? (Circled in red)

I was thinking about pouring it on, but may get messy

1 Like


I finished conformal coating my ESC a few weeks back. I took a bit of a break on the build, but am now back at it.

I tried connecting my ESC to the Vesc Tool, but for some reason, it is not connecting. The ESC appears to be turning on but is not connecting.

I do not believe the conformal coating would have anything do with it not connecting via USB.

Any tips for troubleshooting?

Did you conformal coat the USB connector socket by mistake? This would seal the pins, so you might need to some how abrade away the coating to get a connection.

You could check another socket to see if you still get 5v out, if you don’t then it probably means that all the sockets are sealed up.

1 Like

Looking at the socket closer, I think you are correct. I will put some acetone on the pins tomorrow.

I am bit surprised since I masked the sockets prior to coating (clearly didn’t do a good job at masking them).

Thanks for your thoughts

1 Like

Cleaned of the pins, but it was still no connecting.

I tried different cables and even a different computer

Oddly - my vesc tool app on my Mac is not recognizing the ESC. However, when I try on my Wife’s PC it connects.

Has anyone else experienced problems connecting to the Vesc tool their Mac?

I don’t know for sure but Mac Thunderbolt ports are not USB C although the shape of the port is the same.

If you are using a usb c type cable on PC that works then it might be the thunderbolt port doesn’t like that specific cable that works on PC.

Another option is to connect the 75200 via Bluetooth and eliminate the need for a PC and just use a smartphone.

Of course you have to purchase and then connect a Bluetooth module to the vesc😀

Have you ever connected it with your Mac?

It’s probably driver related. You might need some usb to serial drivers on the Mac.

Thank you all for the suggestions.

@Foilguy : I did not think to try a Thunderbolt cable till you mentioned it, so thank you for the suggestion. It unfortunately did not work either…still no connection even with a Thunderbolt #3 cable. I ordered a Bluetooth module last night, so hopefully it can serve as a possible workaround.

@Strongarm : I will look at the current drivers (while waiting for the Bluetooth module ) to see if this can resolve the issue.


The Bluetooth module did the trick.

Anyone one know how to turn off phase filtering in the Vesc Tool App? I looked for it but could not find it.

here it is

I’ve spend some time searching in the APP (in my case Android) for it too, but till now no luck.

Might not really help with vesc mobile tool but for those who use metr, you can change it in meter under profiles:

Thanks for the video. However, I should have been more clear in the previous post. I meant for the Vesc tool mobile app, and not the PC Vesc software.

After some searching, I eventually found the filters section

  • Motor CFG > change general to “FOC” > next change the right column from General to “filters” > then disable Phase Filters


You can connect you Mac via Bluetooth too … make it easier then mobile app sometimes !!

1 Like