Efoil Build from Philippines

Here’s the box I made for my electronic parts. Slow build but hopefully to finish smooth and working. What can you say? :blush:


Do I need another check valve for the inlet of the pump? Thanks

7 Likes

Nice work. 3D printed box ? What esc connector is that ?

1 Like

Yes. And reinforced with fiberglass inside. 2 connectors on the left for power, 2 out and inlet for water cooling on the right and the big connector for 3 pins from motor to esc :slight_smile:

What is the name of the 3 pin plug ?

Got it from Alibaba. MJ32 from Jnicon with 2pins

Then I designed the plastic holder from 2 pin to 3pin folder. They have more options but this is the perfect size for me.

6 Likes

Here are some of the updated photos of my project. Took a long time for me to post again. I am currently making and searching for the most efficient and cost effective parts for the battery. Need some advice. Thanks in advance.






9 Likes

Is it necessary to use the antenna of the receiver and placing it inside the nose the board? Because I think radio frequency does not work when submerged under water. And the nose of the board is above the water most of the time. Hope to get some feedbacks. Thanks

Hi,
Yes it is necessary, for the size of your board. And try to put fiberglas over antenna ending, instead of carbon fiber.

Thanks for the advice @Nace_Erznoznik . I might test the antenna first outside the board then I’ll find a way to install it inside without making much damage to the board. This is the antenna included by the way.

I finally tested my 65161 with 75200 FSESC using 14s7p config battery pack, just for testing. I have few questions and I hope I can get some help.

  1. Current always shows 2-3Amps displayed on the VESC app and VX3 screen. It is because I am testing it without prop and not under water?

  2. I used UART connection with my VX3 remote but I cannot calibrate using VESC tool. The calibration inside the VX3 don’t seem to work properly. The trigger is too sensitive. It is around 20% duty on my VX3 but 100% on VESC tool.

  3. Is there a way to use PPM but still get the telemetry work and use other features like recording logs?

There is a good Chance it’s working as it should. I went through the same confusion.

The best I can tell, the vx3 only works with current control. Which means when there is no load on the motor, even at low % throttle the motor will spin up to max rpm. You have to put a load on the shaft, and really draw some amps before 20% throttle means anything significant. Keep in mind that current control is controlling based on % of max motor amps you have set in VESC.

1 Like

Thank you for the response. Yes i’ve read that for testing out of the water use duty cycle and current control when testing in water. Do you use bldc or foc? Are you using the same motor, esc and remote?

Just want to know if my understanding is correct?

  1. “PPM” is to control only the speed
  2. “UART” is to control the speed with telemetry but cannot calibrate the throttle.
  3. “PPM and UART”. PPM to control the speed with calibration and UART for the telemetry and other data.

Is “PPM and UART” better than “UART” only? Coz I don’t see any feature how to calibrate the throttle with UART unlike with “PPM”.

I run same motor with vesc 100/250. In FOC mode.flipsky vx3 remote.

1, 2, above are right.

3, above didn’t work for me with the vx3 . The motor didn’t like it. It was not as smooth, made noise. When using vx3 I don’t think it’s intended to run as ppm and uart.

1 Like

I saw a video on how to connect PPM + UART but using VX4. Not VX3 flipsky. Maybe I thought that might work with VX3 with some modifications with the connectors like in the video. Haven’t tried it tho.
Here’s the like of youtube video.

I tried the PPM+UART connection like in the video above. Modified the connector and it seems to work. PPM is controlling the speed but with telemetry. But with few issues. 1 is I am hearing very very small wheezing sound when throttle is 0, (my guess is that the UART is also sending signal like throttling).
2 is that it is interfering with the USB connection.

Is it possible to use PPM to control throttle but still gather data and see telemetry? How do other connect their VX3 remote? Thanks

1 Like

Did you solve this?:slightly_smiling_face:

Haven’t tried other ways yet. I am using pure UART. It works ok in the water because it has load. Current control type. When using PPM, dry testing is fine but I suggest UART when actual n water

Current update, and I’m about to test the board this coming week. Had to perfect the waterproofing of hatch compartment, battery and esc enclosures. Hope this runs smoothly. Battery is 14s7p for testing purposes. Antenna’s not yet placed properly.

5 Likes