ESC or remote issue

I have a strange problem that has occurred after not using my efoil for a couple of weeks.
After connecting the battery, the remote connects ok. The motor will run the first time I pull the trigger, but doesn’t run the motor on the second pull or thereafter.
If I disconnect and reconnect the battery, the same occurs.
My ESC is a flier 400amp and maytech V1 remote.
Has anyone come across this issue.

Update: I just tried another remote and receiver and have the same issue. Looks like an ESC issue.

I had that issue on a swordfish 300a. Eventually they replaced it for a brand new unit. But I never could find out what the issue was. Thing you can do:

  • make sure the ESC voltage cutoff is set quite a bit lower than the battery voltage.
  • make sure your lead from receiver to ESC is not losing connection.
  • try using an external power source for the receiver
  • if all of this fails, get a flipsky 300a or VESC
1 Like

Thanks for your help @Jezza. I just updated the firmware to the ESC, it worked for the first 6 pulls on the trigger, but then failed again.
I’ll try everything you’ve mentioned above.

It’s a Longshot…but did you try calibrating the throttle? I had a similar issue, and that fixed it.

1 Like

Thanks @Flightjunkie I did try calibrating the throttle. I tried a spare remote too, so it’s definitely ESC related.

1 Like

Today after resetting my ESC number of cells setting to auto, I was able to get my motor to run at 20% power. It appears that my ESC is reading the input voltage incorrectly and going into low voltage cut off mode. I checked voltage to the ESC to be good. Now waiting on Flier to get back to me.

I’m now looking at replacing my ESC with a flipsky seal 300 amp, but I’m a little put off by only a 2 month warranty period.
Any other recommendations?

If it’s for the 65161 motor then I’d only consider the seal 300a or VESC options. I don’t trust flier. I have a hifei swordfish 300a but it took over a year and 80 emails to eventually get a faulty one replaced so would not touch them again.

Thanks Jezza
It’s for a SSS56104 geared setup. Flipsky do seem to have an ok reputation, but a 2 month warranty is really disappointing. The Flier has also been troublesome since day one. Thanks for the heads up on the swordfish.

I hope i get not wondering when i start configure my Flier Boat 400A with my Flipsky 65161 :upside_down_face: