Flipsky 200A Vesc6 esc, 65161/100kv and Vx2 remote startup need help

Hi, I just got my setup from banggood and hooked all up but it is not working ok at first. I only get a buzz from the motor when actibvated the remote. Tried with SS56114. It runs like 2 speeds: on - off. So i thought is probably settings. Remote can be setted but i do not know the pole pair nr of the motor. I could set the cell nr to 6. Next Vesc tools. Well, installed but so many warnings i did not dare to do anything. It says that the firmware is old but still working. Any help appreciated:

I was able to upgrade the FW for the esc but i still need help for the motor setting. it is not straight forward, do not have the motor data either.Like pole numbers. wish not to take apart… I am trying with a 6s setup. Do i need a 12 s ?

Read Flightjunkie’s first efoil build. He took apart the same motor and we answered this question. It was 6 poles if memory serves.

1 Like

The Vesc has a low voltage protection, it will limit the current if the voltage is too low. If you set the battery voltage to 12S but are connecting a 6S instead, it will limit the current and won’t let the motor run resulting in the buzzing noise that you’re experiencing. Set the battery cutoff according to the voltage that you’re using.

Did you ever get this running? I have the same setup, except I have 2x6S cells in serial, so 12S. I got the receiver to connect, but the motor will not spin, just buzzes. Based on my info the motor is indeed 6 poles as said in this thread, and I set that into the VESC.

I did go through the Flightjunkie’s first efoil build. He used Flier Boat 400A ESC and 75/300A ESC, no mention of this VESC type.

I have not updated the VESC firmware. And have so far never yet troubleshooted A VESC.

Did you run the VESC tool and setup the motor and remote?

I did run the VESC tool and been now setting up the motor in various ways, trying both the BLDC and the FOC. They both seem to get the motor running when I run the Experiments -> Duty sweep. Also updated my firmware to Fw: 5.1, HW: 60 just in case (VESC_default_no_hw_limits.bin), but after playing with this I can’t blame the fw for the issues.

The FOC motor wizard detects the motor well and controllably spins it while detecting.
The BLDC motor wizard fails in the detection. But after FOC autodetection and switching over to BLDC (like in the VESC howto thread) it still somehow works. So I can run the motor in the Experiments section using Duty Cycle. Current just doesn’t work at all, stutters first, and then drives the motor to a position where the Current indicator is -158A and stops. I remember getting here yesterday. Motor will not move again until I do a hard reset (which sucks because I don’t have the spark-removal resistor yet).

I’m still stuck with getting the remote to work. Yesterday (late, tired) I was able to select, I remember, a control type from the APP settings that enabled the remote to control the duty cycle. Today I can only get the Current as the control type, and Current control doesn’t work at all.

As a side note also the remote has in the settings 11. VESC Thr but I haven’t seen any change in anything when changing between None/Current/Duty modes.

For somebody else struggling with this, read this thread too:

There is an input wizard to select the input method and how to drive the motor (duty cycle or current). You can also calibrate your ppm with this wizard. It is also possible to configure and calibrate under ppm but you need to enable rt data to read the ppm min max values of your remote from the vesc. For dry tests best chose duty cycle no reverse. In the water, when there is resistance, current no reverse is a good choice. If the motor spins in the dry, it will immediately spinn to full speed, because with no load it only takes 2A@ full speed. Don’t forget to save to vesc with A+down arrow for app and M+down arrow for motor parameters.

2 Likes

@sat_be, I’m doing a face palm here. Using the input method wizard helped a lot, I had somehow totally missed that. And knowing that the current control actually does what it’s supposed to do when it doesn’t work without any load. Since I can do dry runs with duty cycle, and the current just immediately goes out of bounds, I think I’ll start preparing the waterproofing of the ESC and then testing this in the water.

You sir are my new best friend!! I’ve doesn’t days on different sites trying to figure this out. switching from current to duty cycle she works like a champ. Gawd can’t tell you how happy I am! 14v 4800ERPM…. When I connect my 48V pack to this am I expecting 16kERPM unloaded?

ASHER