FlipSky FSESC 200A 60V not connecting

Hi everyone
I have the Flipsky FSESC 200A.
I can connect it via bluetooth and smartphone app.
But i cant connect it to my windows 10 pc via usb . device not found…
it shows up in the device manager but there but there is an error:

i cant choose a comport in the vesctool to connect.

i tried 3 different cable and 3 different computers in all combination.

flipsky told my to install “driver wizard” but probleme is still the same.

does anybody have an idea?

thank you!

What I’ve found is that the usb connection on mine is dodgy and I need to put it at the right angle for it to connect. Don’t know if its the same issue or not but its a right pain!

Thank you for your answer!
I think the connection is good because windows makes the sound and shows unknowen device?
If yours is not in the right angle… windows makes the sound? or not at all?

When its in the right angle it does work no issue. Did you follow the instructions on the flipsky website?

Flipsky Tech Support

Data or power cable ?
Some cheap micro USB cables are designed for charging your phone and will not work properly.

ESC power issue ?