Help: Flipsky FSEC 200a 60v and the V6 Bluetooth module

Anyone here who can help me to get the Bluetooth module to work with the Flipsky FSEC 200a 60v.
I have here the V6 version Bluetooth module, and I do see the Bluetooth connection when I scan for it with my mobile (android) phone.

However when I try to pair with it the connection gets refused.
I’m also not seeing any led’s on the V6 module. Is this correct?

I’ve added the module as shown in the image!

Any help apriciated!
Thank you

Connector is the right one, check rx and tx, the labeling is somewhat weird, just swap them and try again.

1 Like

Thank you.
I will try this later today and report back.

Does it have any leds to show that it is working?

I don’t remember but when you can see the bluetooth it must at least be powered. I had the same effect, could see the BT but couldn’t pair the android phone until I noticed I had to swap rx and tx.

1 Like

Swapping the RX/TX wires did not work.
I am still getting a connection refused when I try to pair my Android phone with the module :frowning:

Okay. It’s maybe me who is doing things wrong here.

This is what I have done.
(note that the Flipsky has been setup, and the motor does spinup when triggered with the remote)
I connected the Bluetooth module as shown in the diagram above.
I connected the Flipsky to the power supply (12S12P).
I enabled the bluetooth on my Android phone, and try to connect to the shown Flipsky bluetooth connection.
After maybe one or two seconds I get a message on my phone that the connection has been refused.

I see NO led activity on the bluetoorh module.

I als tried what @sat_be suggested, but still no luck.
I also tested other Android phones… Same results :frowning:

Did you enable UART at the VESC side?
Does the baudrate match?
Which app are you using to connect?

Seeing the module on your phone means it got power. Thats good.
For everything else you need to provide more information…can be anything from hardware to software.


I am using VESC Tool for Android, and no I did not enable UART in the VESC Tool for windows.
I was under the impression that I needed to pair the module with the phone itself (like you do with a headset) :-/

Going to give it another test later today and will report back.

Thank you!

That’s not how BLE works. BLE Connections are handled by the applications itself.

Depending on the Application setup of the vesc tool for windows (when you configured the vesc to work with your remote) the uart can be deactivated and also working at a wrong\missmatched baudrate.

1 Like

Yes. Got it working.
Thank you!

Good to hear, what was wrong?

1 Like

I tried to pair the phone with the module. (like pairing a headphone)
All that was needed was to start the VESC tool on my phone, and “pair” it withing the VESC app itself :slight_smile:
(I did change the TX/RX wires back again to as it was original)