Help! Jet Surfboard Motor not arming. Flier ESC 200A 20S, SSS 56104 motor

Hi Guys,


Running into a problem that I’m stuck with solving and the local RC community don’t seem to be able to help anymore because I working with power way above what they are used to. I’m having issues getting my motor to run. It’s a SSS 56104 360KV (with a water cooling jacket) being driven by a Flier 200A Marine ESC (4-22S). The problem is the motor just beeps at me. Originally it seemed to be a receiver issue and after some stuffing around I got past the initial beeping that it was making repeatedly which seemed to be a communication problem. It’s still only beeps at me but in a more reactive manner. I.e. when I forward throttle I get one tone, when I backward throttle I get a different tone. The tones come out of the motor, but I assume they are from the ESC (sorry - I’m a mechanical engineer so the electronics are all new for me!). So it seems there is some communication now with the ESC but still no motion on the motor.

I’ve tried calibrating the ESC but not really sure what I should be changing it to.

Does anyone know if this ESC/Motor combination is compatible?
Does anyone have manual for the SSS 56104 motor? (Or is it not necessary as it’s just a 3 phase power supply)
Is there any other way of controlling the ESC other than via a RC transmitter/receiver?


Yeah, yeah. Horrible racing stripes I know and they leaked during the glassing. I’m embrassing the chaos though!

Your are im Prog Modos.
You must the throttle way kalibrieren.
With full throttle you bind the battery, then the ESC make tones, and then you make too no throttle.

I’m using 2 Flier 200 amp ESC’s in my jet board.
(same ESC’s as you have)

Some time ago one did not arm (ie: the motor kept beeping).
After resetting the Flier ESC to default and reprogramming it started to work again!.
To make sure it’s not the receiver you could replace the receiver with a cheap servo tester, and test it this way!

Make sure that you power the servo tester with 5 volts as the Flier ESC does not give 5 volts (no BEC) to the receiver / tester!

And. The beeping comes from the motor :slight_smile:

One more thing. When the receiver is not bound to the transmitter the motor will also beep. So also make sure that the receiver & transmitter are bound together!

This worked!!! Thanks.

Although I did it by flashing the firmware to the 3.2. But i suspect it wasn’t the new firmware that worked but the resetting as you suggest. Time to ride!!

1 Like

Good to know. Please let me know how the board is performing.
I’ve only been building boards with 2 jets.
Also. What jet are you using?

Testing later today!

I’m using a home designed jet. I’ve optimized impeller geometry for 10m/s but am able to swap the impeller out for different geometries (I intend on producing a high torque and a high speed geometry variant). But it’s a bit dependent on the testing I do today as I need to estimate the drag co-efficients and thrust efficiencies. (I wish I was able to better verification with a pressure gauge and RPM measurement but you use what you can!)

So I’m lost with the electronics, but the mechanical engineering side is my thing :wink:

Happy to share any specs you are interested in.

Thank you for the info, and please keep me updated.
I personally think that the board is a little bit to narrow at the back.
I also did some testing with fins, and discovered that they are really not needed.
tip. Standing a little bit off center (if you are a regular rider, keep left foot a little bit more on the left side of the board, and right foot on right side of board) will put more pressure on the needed rail, helping you to carve the turns way better.

If you don’t need the fins at Jetboard, it’s too slow !!
The Finns are definitely needed!

I guess it’s to slow than, but it is fast enought for me. And I love doing the 180 flat spins :slight_smile: