Help, losing my mind here

So I plugged my batteries up to my ESC, light on my receiver, but my motor starts beep 10 times which looks like an attempt to rotate. I spend days trying to troubleshoot and out of ideas, please help me.

My configuration: is at such.
Battery - Two Zeee 6S Lipo Battery 10000mAh 22.2V 120C Soft Pack , connected in series. to get 12S, 44V.
ESC - 400A Boat ESC 3-16S LiPo 70V Flier Speed Controller for Brushless Motor + USB Link
Receiver - Flipsky Fully Waterproof Remote VX3 Controller for Efoil | Esurf | ESK8 with Wireless Magnetic Charging
Motor - MSQ High Power 10 Poles 86172 KV160 Brushless Motor

My ESC settings - Cell count: auto, LVC cutoff: 3.2, slow cut off, power: 5%, motor timing degress: 0, PWM: 16kHz, timing monitor: ON

What I am noticing when I hook up to voltmeter to the ends where the ESC to motor connections, I would see zero voltage then a spike to random voltages, when it beeps and tries to turn.

You probably need to configure that Flier ESC. I used a similar one 4Y ago, as far as I remember, there was a windows tool to configure it. You can even upgrade the sw with it. You need a usb to serial adapter, that connects to the 4pin cable that sticks out of the esc. Search the forum for parameters, you should find some information here.

1 Like

Yeah, i figure that was the case, but I tried like every configuration I could think of haha. I also try different firmware too.

Sounds like your throttle channel may be reversed. Can the transmitter be configured to reverse or invert the throttle channel. Some RC gear is like this due to different manufacturers having different standards for how the signal is interpreted.

Sounds like the throttle is not calibrated
Have you tried the following:
Turn on remote, give full throttle, keep pressing
Then turn on the ESC with Motor connected - you should hear a series of beeps
Let go of the throttle - another series of beeps

Then it should work?

I tried that and it still give the same issue. It said ESC battery low. and the motor beeps 10 times.

I tried programming the ESC, I turned off reverse, and only have throttle.

This is the manual for that esc. Are you sure you have the receiver plugged into the signal wire correctly ? Looks like the is a signal wire as well as a usb. Perhaps you plugged it into the USB?

Does the ESC provide 5V power to the Receiver? Looks like it’s an isolated one, so you’ll need an external 5V supply, a 5V BEC for example


Oh yes, so yes supplier just said there is no internal bec so Ill need to get a external to test

But based on Flipsky manual, I can just connect Battery power to Bat+, no BEC need

I think that BAT connection is just for measuring and displaying the battery status on the remote, not for supply…


Oh I see, okay. I will keep yall posted. I need to decide if I want to get a ESC with a internal BEC or just a separate on

We used the same ESC’s (two) in our jetboard build.
You WILL need an external 5 volt power supply to power the receiver.

1 Like