How to Connect ESC to Motor to Reciever

Hi guys, I’m in need of some help!

So I bought some components for my jet build and I am having problems connecting everything together.

I bought two of these below:

2X Turnigy SK3 Aerodrive 6354 Brushless 260 KV Motors
2X X-Car Beast 150A ( Cheap for testing )
1X Program card for this ESC

I have a 2.4 Ghz controller from Amazon.

I am having trouble getting the Controller to move the motor. I have connected my Lipo pack to the ESC and the receiver to the ESC’s BEC on channel 3. The receiver and controller connect and the lights go solid. But there is no motor beeping for the number of cells in the pack? And the controller does nothing.

So I calibrated the throttle by holding the set button and then moving the throttle and waiting for a beep. (it beeped after I moved the throttle so I know the controller is connected and so is the Motor to ESC)

Then I turned off the ESC to save the data and turned it back on and then the throttle does nothing…

Am I missing a trick? I’ve attached a video of my attempts.

Cheers Guys x

I have the same esc but a sk3 149kv and maytech remonte for my eskate , i don’ t recall any problem with it , but i set it up with à programing boxe , as far as switch it on: i apply full throttle ,switch on , beep, and let go the throttle and beep again… And good to go

1 Like

Can you test motor directly to battery?

1 Like

What did you set your stuff to on the programming box? Because I have the X-Car LCD card and I went through and put all of the settings in and then turned off the ESC to save them. Turned on and no luck…

I’m not sure how you do this

Reverse , soft brake … Try to switch on after apply full throttle or to change Channel (?)

1 Like

I have the same remote. Did you try receiver output 2? 1 is steering and 2 thrust.


Thanks! I have tried but no luck :frowning:

Thanks for the help! It have it in channel 2 but still no luck. Maybe it’s a problem with the ESC not talking to the receiver?

Possibly something to do with the Trim Switches?

Trim normally set to middle
Press Set full front full back and Neutral

1 Like

Thankyou! Just got it working!