Maytech reciever clicking and not connecting to remote


I have a problem where my Maytech reciever started clicking and not connecting to remote control.
It happened after using it for about an hour on a jetsurf board, and now i cannot get it to connect with the remote control.
The reciever starts blinking as normally, and when i turn on the remote it starts with the clicking sound, so there is some kind of connection between the two but the antennae indicator says zero signal.
Tried to pair them again, but that did not work.

Here is a recording of the problem:

It is a “Maytech MTSKR1905WF v2 Waterproof Remote Control” and i have tried contacting their support, but they do not answer.


My bad, had accidentally activated the “Relay switch suction and release” mode according to the manual, why that mode is still on after turning the remote on and off is beyond me, but once disabled everything was working again.

1 Like

Had same fault mine was my BEC dropping volume on startup, replaced BEC fault went away.