Maytech remote won’t pair - red light kepps flashing

Maytech remote won’t pair - red light kepps flashing

Anyone had similar issues, I am following the pairing instructions

Fixed it, see this video

Turns out you need to press the brake button to finish the process and this isn’t stated in the instructions.

That then takes you back to the main screen and the light goes solid red

1 Like

Nice that you got it paired… But according to Maytech’s howto it does say press brake button

  1. Long press function button for 1 second to enter pairing status, when screen shows 【…】, turn on the receiver, it will auto-pair with the remote in almost 0.5 second, short press brake button and return back to main interface, receiver red light lights steady, and signal show in the left corner of the screen, receiver pairing successful.

Have you tried the auto-pairing procedure with receiver side switched off as recommended in FAQ4 of the user doc ?

Did you calibrate (menu 5) to make sure 100% throttle on the remote side corresponds to 100% PWM on the ESC side:

Can you buy recover only? Mine got wet and no longer works.