Problem with the ESC


I am currently building a hydrofoil with these main components:



Batteries in 10s config (6s+chopped off 4s)

And I am using an Arduino for the control signal. The problem is that I can not get the ESC to spin the motor or to calibrate. After plugging the batteries, the motor beeps 3 times and according to the manual this indicates that it enters calibration. But no more beeps after that. Normally it should beep again to indicate that it caught the max throttle, etc… But nothing and it does not react to the input signal at all while turning the potentiometer. I have checked all the connections and voltages with a multimeter and everything seems fine. This configuration used to work with the last ESC (VESC), so the signal from the Arduino was good. Could it just be a faulty ESC?

Thanks in advance!

You may check the ESC without the arduino first and with your 6S battery only, calibrating your ESC (connect your battery when transmitter is in full throttle, then throttle at zero). Then disconnect the battery, and reconnect it, with throttle at zero. You should hear 3 beeps, then 6 beeps, then 2 beeps. Then give it some throttle to check that it works.

If it does not work,try the same with only your 4S battery.

Unfortunately, I have previously tried it with 4S and 6S also. The 3 beeps got quieter but other than that, still the same result. I guess the strange thing is that nothing changes when I disconnect the receiver cable, still the 3 beeps no matter what. I also had an idea that maybe the signal is not even reaching the ESC somewhere inside it. But I can not check that because the unit is factory sealed.

I would check the PWM pulse with a scope. Maybe the pulse width or frequency is out of range. I’m using a DSO 212 for $100. Very useful tool.

I had a similar problem where my ESC was calibrated with an RC receiver then when I used with arduino it wouldn’t work but I knew the signal was working because it would drive a servo. Turned out to be the frequency of the PWM signal was slightly different and the ESC didn’t like it.

  • First I’d check with a normal RC receiver.
  • Test you can drive a servo with arduino PWM
  • Double check your PWM frequency and min / max values are right.

What kind of 3 beeps ? 3 dropping tones ? 3 short or 3 long beeps ?

  • Your batteries may be discharged (I guess not)
  • You could be in reverse mode, meaning you calibrated from full rear to neutral :slight_smile:

3 dropping beeps. The batteries are 40V (10S), so it should not be a problem.
For the reverse it is written in the manual:

Note:SwordfishX ESC can not run in reverse. If throttle range were calibrated from reverse
to neutral, the calibrating range will be invalid.

But I could not calibrate it even once, so I do not know if that is possible.

And I guess I am gonna test it with a normal receiver once I get my hands on it.

1 Like