Propulsion Help

Hello Everyone,
I’m new to this, still learning (a lot) and need some help with the propulsion system. I have an SSS 56104 motor and a KV103A ESC with a remote control programmed; however, I can’t get the motor to work (turn) yet. Its just emitting a constant beeping about every 2 seconds. Not sure where to go next. Sorry for the remedial question, again, just getting started and I cannot find a troubleshooting guide for this motor. Would appreciate any help, I searched forum before posting but couldn’t find anything that helped solve my problem.

Thank You!

Sounds like it isn’t picking up on the remote receiver. You need to look at the documentation for the ESC, not motor, to tell you what the beeping means.

Thanks Tyler, Ill check it out… didnt even know where to start!

Does your esc have a built in 5V supply for the receiver? Otherwise you need to connect your receiver to 5v via UBEC, the beeps could be the esc telling you that there is no input signal from the receiver.

I do have a UBEC attached and connected it according to a diagram. I haven’t tested it to confirm a 5V output; however, it is attached to the receiver and I do see a light there. Also, the diagram I had instructed to connect the red and black (power) from the UBEC but use the white wire that goes to the ESC. Does this sound right? .I feel like Im missing something obvious…
Really appreciate the help!

So this is what I had to do with my setup (realize each is different):

I used this cable…

…to connect the UBEC black/red (or brown/red in my case) to both the ESC and the receiver. Then the third wire which is the signal wire (yellow for me, probably white for you), connects from the ESC to the receiver. Try that and see if it doesn’t work for you too.

I didnt get that cable but it sure looks like everything is hooked up correctly. Im starting to wonder if my esc is bad. I dont like to just blame it on the ‘gear’ but…
I have a UBEC connection (red and black) to an AUX connection on the receiver. Then I have a white and black connection from the receiver to the ESC. As I understand it, the receiver is powered from the UBEC and then the white wire from the throttle connection from the receiver ‘talks’ to the ESC. I read that the red wire from the ESC to the receiver should be disconnected but the black wire from the ESC to the receiver should stay connected.
So frustrated! This seems like the easy part! Might order a new ESC as Im just out of ideas!

The red/black wires must power into the ESC too. I know it sounds weird but you must provide power into the ESC as well if the ESC doesn’t have a BEC onboard. Just trust me on that one.

Also, provide pictures to help paint the picture.

I disconnected the red wire from the esc to the receiver. Do you think this one should be plugged in? I uploaded a picture of how I have the electronics currently connected.
Again, so sorry for the remedial question but Im new to the esc & ubec setup. I really appreciate all the thoughts and help!

With the seaking ESC the red wire needs to stay connected.
You only need to disconnect the red wire if your ESC has a bec built in, which the seaking does not.
I hope this helps

Yes I think with opto ESC’s (no bec built in) you need to power the signal input part of the ESC through the UBEC (via receiver). I did it this way with my flier ESC (which does not have a built in bec). In the receiver all GND pins are connected as well as all the +5V pins. Like this you can use standard 3 pin connectors to connect, servos and ESC’s to a receiver. If an ESC with built in BEC is used, the same receiver can be fed through the 3 pin cable of the ESC and no external UBEC is needed.

Check ( i know again …)
Order of power ( maybe the esc needs a signal from the receiver before it gets the power from the battery …)
Zero throttle : program the esc with the propramming card may be needed before apply the power from the battery , or try to power everything with full throttle on the remote , wait for the bip then let go , some esc needs power on full throttle then let go to zero then full reverse
Don’t let go , it s very frustating but there is so many ways to start a esc …

Thank you all again for your help! But, no love. I reconnected the red wire from the esc to the receiver (along with the white and black). Nothing. I disconnected the motor and tried the process again. Nothing different.
The transmitter and the receiver seem to be bound but nothing from the esc. I think. The blinking led on the reciever turned solid so Im assuming that its connected. Starting to make me think there is indeed something wrong with this esc so I contacted Seaking and sent them the same diagram I uploaded earlier. Waiting for their response.
Also ordered a different esc to see if the same thing is happening.
Ill update with the results but if any more ideas, keep them coming! Appreciate the help!

Yeah the Seaking needs power from the BEC on the signal wire line, and the receiver needs power too, and then the signal from the receiver to the Seaking. If remote connects, the receiver should stop blinking so that’s good. I thnk you’re almost there!

Ya’ll are Great! Its working! Currently running backwards but I think I can fix that. I used the throttle reverse switch but then the thing goes full throttle. Should be able to figure that out but OK for now.
Im not exactly sure what changed so that it started working. I did plug the red wire from the receiver to the ESC back in (thanks Rogjalon) and initially nothing changed. But I think what Alexandre also said about the order of power may have been the trick. I disconnected the motor too and tried the setup that way. Again, initially nothing. However, a friend stopped by and I was showing him the electronics and explaining the problem. i reconnected everything , motor included, and bam! It worked. Not sure why but at least things are moving!
So… for anyone else struggling.
Seaking KV103A esc needs all the wires (white red and black) in order to get the receiver to work and the esc calibrated.
I disconnected the motor (SS 56104) during the calibration and not 100% sure that was the solution but after I calibrated and reconnected the motor it runs. Maybe something to that.
Followed the instructions on my remote control to calibrate but may buy a programming card to ensure the timing, battery cell count, … are correct. Not certain that its correct as of now and need to play with that a bit.

But… some success! Thank you Very Much to you all for helping me figure out this part! I was really frustrated as I consider myself fairly competent but just couldn’t figure it out! Very much appreciate you taking your valuable time to help out a newcomer!

1 Like

If your motor is spinning in wrong direction, just swap two of the three phase wires between motor and ESC. Dont mess around with the throttle or programming. This might not work with sensored motors (which most of us do not use).

^ Yeah, just switch two of the motor phase wires and it’ll spin the opposite way.

That did the trick! In my excitement/testing I forgot to secure the prop to the shaft and now… I have to reprint it. (bounced off the wall and ceiling!). Nobody hurt so just a hiccup! ; )