Sudden lack of power

I have been using my hydrofoil well for a few runs but have suddenly developed a lack of power when being in the water for around ten mins. Set-up is a 12s battery, Hobbywing seaking 130A ESC, SSS420KV motor. The battery is still nearly fully charged, and nothing feels to be overheating. I have tried a different remote however this hasn’t helped. I have checked the output voltage of the battery and it is giving out the right voltage. How can the speed of the motor drop when everything seems to be in good condition? What could be causing this?

if you are using a shaft coupler , check it, most of the time the lack of power is caused by a spining between two shafts (motor/gearbox or gearbox /prop shaft), hard to tell without taking a part, you will see the grinding on the shaft, better glue it as well with loctite

no sign of burn, high speed in the air (off load), no “power” in the water (on load) = free spinning under torque

1 Like

I have cheap Chinese on
Worked good last year
Tried it this year
Motor works for awhile then just stops sometimes restarts up right away
Or dies reset mag safety swithc then seems to work
Some times but dies sooner or later and get catapulted
If up to speed

Opened the watertight connectors from controller to motor
And found water in them
Strange connection looks kinda like 1/4 mike…pa plug
With c clip on it
Didn’t want to break it asking it apart
So sprayed contact cleaner and twisted around

Seemed to work good on land on water same stoppage
Then on land after water some stoppage but seems to run better

On throttle I looked at the cr2032 battery had just a bit less than 3 v
Ordered more
But recharged in mean time

Can loss of signal from hand “throttle” make it surge or not stop

Any ideas appreciated

After contact cleaning
I sealed it up with silicon caulking