Ugly board V1 - bad VESC? Help

So I was all excited to get Ugly board V1 in the water yesterday for my first ride. The setup is very standard. Maytech 120 KV motor, Mayteck 200A VESC, 12S Lipo, and a Naish wing and mast. I got all the electronics installed in the waterproof boxes and I attached the VESC to my computer and ran the VESC tool. Everything works great. I test the remote, that works great as well. I disconnect the battery and leave to go play golf. I come back. install the batteries and close everything up. I run one more test before heading down to the lake and the motor won’t turn when I use the remote. The green light is on at the VESC and goes bright when I hit the remote trigger. The RPMs even show on the remote but no spinning. I double check the battery. All tight and proper voltage. I hook back up the VESC tool in case I forgot to download when I finished with it in the morning. I go through the setup wizard again and it says “success” but the whole time the motor never turned over.
So incredibly frustrated…anybody have any ideas? Thanks in advance for the help! -Marc

Tried a different motor after running the VESC tool. The tool detects the motor just fine but doesn’t spin it. I have another VESC so I guess I will try install that and see what happens.

So the motor was spinning when you first did everything? I wonder if the remote part of the VESC tool you had configured and wrote properly? RPM’s/throttle on hand remote don’t mean anything.

Well, I have tried rewrite it but now I can’t seem to even get the motor to move while I detect it. No noise or anything.

And yes the motor was spinning. Literally everything worked, I shut it down and now it doesn’t. Doesn’t make sense. I assumed it had to be a connection issue but those are good. I also connected another motor and tried to detect in in the VESC tool and I get the same result. The wizard says detection successful yet it never made any noise or turned.