VESC 6 won't start motor in some positions - Motor Current Max Brake

I found an interesting VESC bug/issue. I’m using a maker x hi 100 and a 65161, but in retrospect I suspect the same issue was occurring on my foil drive build with a 6384 and a smaller vesc.

When I changed ‘motor current max brake’ to 0 in the VESC tool, the motor will not reliably start. I’ll give it throttle, and some times it will start up and work perfectly, but the other times it just sits there not doing anything. When it won’t start, you’ll need to turn the prop slightly and then it will start ok.

As soon as I set the value for motor current max brake back to it’s default value (or any other negative value), the motor starts perfectly each time.

I have been setting this value to 0, because I didn’t want/need any regeneration because I’m using a propellor. I’d recommend just leaving it at default.


You should not have to change the brake numbers at all as that has no use in this type of application.

Rather you should select the mode that says “no brake and no reverse” This can be done either when you set up the Remote or afterwards through the PPM tab on the left menu.

There are a few other areas to change this to but just let me know if you need some more info.

The max braking current isn’t relevant to our use, which is why I had set it to 0.

I thought it would be helpful for others to know that this causes issues with motor startup, surely that’s a bug.


Thanks @Jatem !! You saved my day! Been struggling with my Tow Boogie recently. Sometimes it does not respond to my remote input. And now when I saw your post I tried to change the brake current and it solved my issue!! I am also running on a MakerX but the Hi200 with the latest VESC fw and running a Flipsky 65161. But my setup always starts but sometimes with quite a delay. See this short

I reasoned in the same way as you, I do not wan’t to risk any regeneration and thus set it to 0A.

1 Like

Had the same Problem, setting brake current to -5 solved it (at least in dry tests)

thank you @Jatem