Vesc A200S (75/300) ESC and Flipsky 65161 120KV 6000W motor issues

Hi Folks,
I would like to ask the more experienced VESC users. Finally I got myself one of this Flipsky inrunner. Today I made a short testride with my esurf (repurposed inflatable SUP) to test it. I’m a little dissapointed from results. The motor not go over 80A phase current, and more than 45 battery current. The duty cycle on full throttle is only 59%. The VESC limits are set to 120A battery current and 200A motor current.
Prop is cheap one aluminium bundled with motor, but cut down and reshaped. Battery 12s, 42Ah BostonSwing.
What I’m doing wrong? I think something in VESC setting is wrong, but I don’t know what. The automatic motor detection went smoothly, motor paremeters looks OK. Off water the motor run at 4900 rpm 98% duty cycle which is OK. Can someone point me what I overlooked in VESC setting? Maybe run large inrunner motor detection instead medium inrunner?
Thanks. Louis.

You need to set you max current values higher.

I had set the VESC limits to 120A battery current and 200A motor current. Absolute max. current is set to 220A. That’s are the max. limits what my A200S ESC can do.
The problem is that motor not take more than 70-80A phase current. Now I tested different battery, LiPo 20Ah, 12S, no change still small phase current. Tomorrow I try new motor detection as large inrunner.
I hope this fix the issue, as I read in this thread: FR Motor and VESC 75/300 without any power

I have no experience with flipsky motor but…
You should probably check your vesc temperature under load. To run at high current, vesc needs cooling (passive or active). Otherwise it starts throttling down the current.

I have, water cooling that’s no the issue. Look at the posted pictures the mosfet temp is 32.5 deg.C.
Simply, this VESC do something with duty cycle at full throttle in water the duty cycle reach only 59% no more as I highlighted in posted pictures. That’s the issue which is limiting the motor curent.
In my old esurf with C80100 170KV fully submerged motor with YEP120 ESC no problem draw from battery near 100A with this battery, and prop. If I hooked to this motor my VESC A200S ESC same issue happend. No power, the motor draw from battery only 35-40A, phase current. I have two A200S controllers, same result.

Hi. Did u fix the problem?
I allsow experience simular problem.
Not getting more than 3000w on full trottle

Unfortunately no. Still struggling with this issue. I tried different batteries, replaced the motor still no more power. I don’t have another VESC to try out, but my two A200S have the same behavior. I am near to give up.

I had the same issue with mine and was never able to resolve it. I had the A200S v3, what version are yours?.
Maybe it doesn’t play nice with inrunners or it’s simply overrated for what it’s capable of. Either way it was very frustrating!.

Mine is A200S v2 :thinking: