VESC limits power after 15 sec


I have just finished making my second e-foil. But now I have encountered one problem, where I need your help.
When I give full throttle, it takes about 15 seconds before the motor makes a strange sound, and I lose a lot of power. If I let the throttle down to about 70%, the sound is gone. I have to let the board sit for about a minute before I have full power again.
I gradually lose power from when the VESC is about 40c, and it gets worse the hotter it gets. I have set the temperature cutoff to start at 80c and end at 90c.

I also have problems starting the motor when it is stationary. 50% of the time, it just makes a sound and stopps. I don’t know if this is related to the other problem
I have set the number of motor poles to 6.

My settup:

-Spinted 80V 100A (it is now named 85V 150A, same hardware)
-Flipsky 65121 motor (130 kv) (filled with mineral oil)
-16s 1p 4680 cells (30ah each, 1776 Wh total)
-Daly 16s 100a BMS
-maytech remote
-PETG proteller, Diameter: 6inch Pitch : 7 inch, to blades

This is my VESC settings:

-Absolutt max current 200a
-Motor current max 135a
-battery current max 98a
-battery voltage cutoff start 52v, end 48v
-MOSFET temp cutoff start 80c, end 90c
-Acceleration temperature decrease 0% (tried 15% )
-Duty cycle 96% (i get to 50% on static thrust test)

I have tried the following things:

-set “Acceleration Temperature Decrease” from 15% to 0%

-smaller propeller

-checked that I have a constant voltage of over 60v under load

-checked that the phase conections to the pluggs are cool to the touch under load

-upptated to the latest VESC firmware

-changed motor current to diferent values

-changed temperature limits to diferent values

I really appreciate all the help I can get! looking forward to having two oprative
e-foils :smiley:

No real advice, Cool to see a build with 4680s where did you buy them from?

That’s a lot of current through those series connections, but it shouldn’t be cause the issues. Are you getting much voltage drop at full throttle?

It sounds like temperature related but 40C is pretty low to have any limits. What the max temperature that you see?

Can you swap parts from you other efoils to isolate the problem (it is most likely the vesc though)

I bought the 4680 cells from Alibaba. They are rated for 10C continuous (around 300a). I use four layers of 0.2 mm nickel strips for the serial connection.
It is a voltage drop off under 2V under full throttle.
When I just keep holding full throttle for about one minute, I got 50°C

I will try swapping parts from the other e-foil tomorrow.
Thank you for replying :slight_smile:

What are your bms settings? Ie cell deviation, max temp, amps, volts etc? Also what vesc are ya using?
You can try change Change your current controller decoupling type to the “original” this may help with startup problems.

get rid of the bms and see if it that works.

Based on your 16S voltage, these are LiFePO4 chemistry not Li-ion cells.

The 10C is a “China” rating - it will be more like 1C max, but probably closer to .5C and the capacity won’t be 30amp, maybe 15A or possible 20Ah.

Based on this the VESC is not the issue and it is the supply sagging at full power. The recover time is until the cells recover.

Screenshot of a BYD cell which is high quality.

I have tested the 4680 cells to 29,7 ah. They are on the more expensive side, and they are definitely li-ion.
The battery pack have a voltage drop of 2V under full throttle (0,125V per cell). That is pulling 58 A from the battery.
That BMS is Daly (not smart BMS) 16s 100A
I’ve made sure the voltage was stable and over 60V under testing.

Therefore, it seems like the problem is the VESC, or after the VESC.


I have tested the vesc on my second e-foil, and then the problem is gone. The problem therefore appears to be the motor. I measure a “Motor flux linkage” of 63.33 mWb one time, and 34,09 mWb a second time. This value appears to be too high and varying . (My other motor has a “motor flux linkage” of 16.19). Could it be an idea to drain the motor of mineral oil and try again? or I might have to buy a new motor.

update later the same day:

I tested the motor in fresh water, and the problem was gone. When i took it back to salt water, and tested it the problem was there again. any idea what the problem can be?

Could be a problem with the isolation of the phases which could lead to current bypassing the motor. As salt water is a much better electrical conductor than fresh water, this could also explain the different behavior.

1 Like

Nice prop :smirk: keen to see how the petg holds up with this much voltage

Yeah, sounds like bad calibration parameters for the motor.
Can you share a screenshot of the whole motor parameters tab?
One thing you can try, let the motor run at e.g. 10% duty cycle constantly. (Bottom left of VESC tool, where it says “D 0.1”, just click on the play button. Then enable real time data an look at current and duty cycle view on bottom right. Which current do you get in the unloaded state?
Just to be sure you can also follow this video to fully configure the VESC again, to make sure you didnt miss any step: LINK

I will upload more data later

It’s 100% this… It just depends not on where the phases are shorting.

1 Like

Update: I ordered a new motor.

I also dissembled one 4680 cell. They use tabless technology. This allows the cell to have much lower internal resistance than 21700 and 18650 cells, and therefore it can deliver more current.

The seller claims that these are cells manufactured by Tesla. Can anyone here identify whether the cell appears like genuine Tesla 4680 cells?


I’m surprised they can fit 30ah in a 4680 cell. It’s definitely 80mm long? I can find a bunch of 4695 30ah cells. Do you know how much the 30ah cell weighs?

The cells were actually 95 mm long, so can’t be a genuine Tesla cells. I still like them though, it it to make a battery pack with them, and low internal resistance.
They weigh 415g each

1 Like

4695 makes so much more sense. I have been searching the internet for hours trying to find 4680’s that are that energy dense and I gave up haha. I think the 4680’s max out around 22.5 - 25 Ah. I think you have convinced me to pick some up. Rivian is developing some new 4695 cells but I doubt they are made by them or Tesla. Doesn’t mean they are bed cells though I have had plenty of luck with Chinese cells.