VESC not allowing Amps above "SETUP" for MakerX HI200?


I was previously running the HI100 MakerX VESC and coudl setup the motor which defaulted to 50A which I then upped to 85A and there was no issue, it allowed this no problem.

Now I am setting up the HI200 and go through the same process (VESC tool 3.01 and Firmware 5.3) and it still give a setup of 50A but even though I change the max to 85A and it is confirmed that the esc has it written, it only delivers 50A at max throttle.

I have setup multiple times and confirmed multiple times that the Max current is 85A but still limiits to 50A

Battery us 12S 22ah, 25C, setting on VESC is 200A for battery but tried higher values to and made no difference.

Has anyone had this happen before or point me in the direction to resolve this, using a Fero remote so cant use the VESC app on the water so rely on the outputs from the Fero to confirm Amps.

Thanks in advance

5.01 FW works well for me on a Hi200. I change settings like max curren and max motor current on my mobile (metr app, modes) through a metr module connnected to the vesc. Works flawless.

Downgraded to 5.02 and still no Amps above the Setup even though the write Amps off the MakerX reads 85A

Tried a second HI200 with 5.02 and exactly the same issue, so my feeling is that it must be the HI200?

@makerX-david can you please confirm what is going on here?