VESC tool throttle setup


Any tips regarding VESC setup of throttle input, PPM. I use a RC transmitter and receiver. I’ve done the basic wizards and got it running.

Any tips on the ppm mapping of pulse length?

I use no revers and no break.



You can modified the shape of the curve , I like it more flat « on the end » it gives a long play on the trigger past 50%

Positive ramping : add some delay , make the trigger « less sensitive «

Hi Alexandre-

Thank you for the tips. I did not modify the shape of the curve for my quick build and had poor throttle response: cogging until what felt like 50% and actuation above. Would you mind posting a screenshot of your modified curve?


Will look for it , but it is like : exp +40%
If I correct , remote signal in bottom and vesc duty on left , so small increase on bottom with big increase in left will give you punch in start and more control for top speed

1 Like

Thank you!

Did you go for “current no reverse” or ”current no reverse with break” and small break value?

I don’t want break since I have a gearbox between motor and prop.




I’m trying to set my max current to 130A but I get a message that it is truncated to 120A because 130 is outside of its allowed limits.

I’m doing changes under motor settings-> General -> motor current max.

Does anyone know of another place in the Vesc tool where the max A for the motor is set?


have you the no limits firmware installed?

It’s a 200A esc, supposed to handle 230A burst.

I’m thinking it’s the work of the motor wizard in Vesc tool, some value that’s the limiting factor.

You can break the limits by using the no hardware limit firmware. Android App example below:

No limit software loaded!

1 Like

Hi! Up and foiling now.

I’ve set max current to 150A but metr is showing nothing close to that value. VESC won’t go higher then approx 110A. I use FOC mode.

When looking at rpm in metr, I guess that it is ERPM, I get approx 40000. I use a sss56104 with a 5:1 gearbox. Should be able to hit 60000 ERPM on 48V.

Does anyone know what the limiting factor could be?



There are three current settings at the vesc tool.

Max motor current
Max batterie current
absolute max current

What are your settings at these three parameters ?


This are peak values for today’s run.

And what are the values in water when the board don’t move?
Static in water.

Erpm : 45,4v x 61% duty x 500kv(?) x 3 = 41000
Which what you got if you have a 500kv

  • static test to see if amp goes up
  • off load test to see if you can have max duty and higher erpm
  • remote endpoint ( max duty)
  • duty cycle control is better to do those test rather than current control
  • settings , max power , max erpm on vesctool
  • Max temp setting and lower voltage start cut off can reduce power as well
1 Like


Thanks guys!

Did another run after changing the “acceleration temperature decrease” to 5% I also upped the “max duty cycle” to 96%.

I did a static test and blew the coupler between the gearbox and the propshaft :slight_smile: weakest link…

I didn’t have gps in the recoding above but it was waaay faster than the earlier one.

And 500kv is correct.

You gain 400rpm on prop probably by increase the temp limit , may be need a better cooling for higher top speed
You can reduce the bat and mot amp to save the coupler …
140 motor ( 131 recorded)
100 batt ( 70 recorded)

Fixed the coupler, I got stuck in sea weed last year and the coupler slipped, the shaft has some grooves in it from that accident so it’s not 100%. But it’s better than breaking the gearbox.

Saw that you were talking about VESC in another thread, can you verify that the “motor poles” setting for sss56104 is 6? The wizard detected 4 but the specs for the 56104 says 6, 3 pairs.