Vx3 & 75100/75200

Hello, I have searched the entire forum but I have not found the solution to configure the FLIPSKY VX3 and a FLIPSKY 75100 or 75100 with VESC TOOL.

I can’t see the temperature of the VESC, or Amps, or Watts.

Does anyone have the same problem or has it configured correctly?

this is my setup

I have already tried to change RX and TX

Thank you

What esc type is Set in the Remote?

the set in remote is VESC

Try fsesc

20 character

20 character?

i dont understand, where can i choose this option? in the the Remote?

Yes choose in the remote

20 character is only to get at least 20 character :joy::joy:

Just choose fsesc as esc in the vx3 and try

Hier ab 4:30

Hi Toto44

nothing, with FSESC it does not send any data.

in the WIZARD, the only thing that matches is the NRF controller. It calibrates the VX3 trigger fine but then it doesn’t send any data.

Vesc remote does not work in vesc tool???

I mean that in the VESC TOOL I execute the WIZARD in NRF controller, and it recognizes it perfectly. And the remote trigger raises and lowers Duty on VESC TOOL, but dont shows temp, W, amp…

Try to use vesc remote in the vesc software. Choose vesc remote an then current no reverse.

…make sure the RT button on the right side of the Vesc tool is turned on

yes of course it’s on

Did you try the vesc remote? Set it from “OFF” to “current no reverse”

did you connect the wire from the receiver to the battery + ?

no, but it is assumed that via UART it is not necessary, like temperature

It looks like it says RP on the remote in the top left of vx3. That means it’s connected using PPM not UART. When connected to UART it will show RU. You need to connect the receiver to the COMM/UART port on the VESC (4 wires) and then configure your VX3 to be in VESC or FCESC mode.
Then ensure you set the VESC-tool to Current or Current no reverse as shown above


Also don’t forget to setup in App setting → general. You need to set App to Use to UART. That one took me forever to figure out. And don’t forget to write the config to the VESC by clicking the approciate non-intuative icon on the right side of the UI. It’s one of the As with an arrow (down arrow I think )

Is there any easy way to use duty control with VX3?

Thanks, i’ll try in a few days