Bluemind Waterproof Intelligent Remote Controller

What about the cruise control ? Have you tested the feature ?

Yes, press and hold the + switch.
The symbol in the upper right corner will change.
I think with +/- button you then could set throttle value in 10% steps up/down.
What I asked myself was, if there isn‘t a safety function to immediately set throttle to 0%. For example when you pull the trigger. When you are falling I don‘t think that you are able to press several times the - switch until throttle is 0%…
I will test it later again.

But as I wrote, hard to do because of bad switch behavior with my remote.
I don‘t think that I‘ll be able to do it while foiling.

After the subsequent program update, the accelerator can be reset to zero by pulling the accelerator trigger when you are cruising. When did you buy the remote control?

When you bought the remote control two months ago, I was not sure whether the program had been updated. You can try to reset the accelerator to zero by pulling the trigger during cruise control.

The program of the remote control is constantly updated. The functions of the remote control purchased at different time points may vary. If there are any problems, I can tell them here. I will contact the remote control engineer to solve them as much as possible.

One thing that isn’t clear: can a recent remote be updated with the latest firmware to include the most recent functions ?

Yes, but to destroy the waterproof layer, open the remote control, and the waterproof function will be lost.

Do you intend to implement a wireless update feature ? If yes, what would be the extra cost ?

What is the process of updating the TX firmware?

Where can I download the latest FW?

Our engineers are studying the remote update system, and I will inform you of the progress.

Our engineers are studying the remote update system, and I will inform you of the progress. Maybe it will be free.

Hello, thank you, by setting the ST to 0 I managed to connect to the vesc. It still does not show the voltage on the on the vesc or the rpm of the motor. Have you got this to work? What does the BN, PP, TC and ST stand for? I was planning to use the same setup for efoil and for power assist pumping so I need to be able to access the Vesc with bluetooth. I have the new Flipsky 75200. It only has one uart so if I use this for the receiver I will not be able to access the Vesc on bluetooth. Any solution for this?

Usplit is supposed to but I haven’t tried the one I bought yet. Available here. Products – Solid Circuits

Thank you, will try.

Can you help to set it up. I can run the motor with uart connection however it does not show any data, rpm, voltage, amp. I run another remote the Flipsky Vx2 and this one gives the data. I have tried different settings on BN, PP, ST is 0, TC 1,71. I do not know what it means. I did ever try to switch RX Tx but that did not work at all.
My receiver has an antenna.

From the manual:

Main Menu Enter/Exit: Hold buttons + & - for 2 seconds
Submenu: Double Click Button + to select submenu
BN(Batteries number)
PP(Motor pole pairs)
ST(Signal type): 0:VESC TTL 1: PWM
TC (Throttle calibration): Release the trigger and press button - to display and set the minimum value of throttle. Pull the trigger to the maximum, and press button + to display and set the maximum value of throttle.(Use this function with caution
Set Value: Click Button + or - to change and set value

This is the picture of the receiver if it can help the mandufactor @qdbluemind to identify which version I got. Shipped Nov 2022.

Thank you for the info, I did make contact with the company, hopefully they will help me.

It is amazing the controller you developed. I am making the opposite, to use an Esp32 microcontroller to communicate to the bluemind controller and also control some new warning system and later to control the angle of the motor into the water. I probably burn my nRF5280 :disappointed:

I am trying like hell to extract and understand the protocol of the controller nRF52840. I had already extract the binary code and also convert to some C low code structure, hex, using a dissemble program (radare2) and raspberry 4 ports and OS. I could share the code with you, but tou probably already have it . :sweat_smile:

I am not getting how to communicate to the controller. It’s look like to be Bluetooth in 2.4GHz but I am not finding it. Maybe the is some hiding function and password .

could you also share with me your communication code? :blush:
And maybe some info about how to communicate to the original controller. I am desperate and my wife is already blaming me and my board, because I am spending to much time trying to fix this problem and that I should spend more time doing something else :disappointed: