Custom Flier 400A Firmware collection

So It seems a lot of people are having same problems with Flier ESC as I did when driving MP56115 with it.

So here is my collection of custom firmware I managed to get from Flier.

Since I was driving a different motor it’s hard to say witch will work best.

For me it was:

Happy testing :wink:

Thanks, I tried all of them but none of them is working at the flipsky 100kv

Do not work at all or do not switch to the closed loop?
have you set start power to 100% ?

Closed loop?

I did not do any settings. I just ran it. So try all Again at 100% startpower?

1 Like

Yes. The lack of start power is the main problem.
Step 1: flash new firmware and disconnect after it’s done
Step 2: connect and check all the settings.
Step 3: set start power to 100% and timing angle to 25
Step 4: if the motor is running good change the timing to 0

Hope it helps.

Thanks a lot for help.

Start at 100% is really too hard.
Tried all kind of different settings. But 90% looks OK now. All Firmware and settings that I tried only run really smooth at full throttle. Maybe good enough for foil testing

Wich Flier ESC you are using?

500a flier. Really big.Almost 3x the size of 400a

I have the white 400A Boat.
Is there a difference to the red aluminum one?

From what I understand all Flier ESC’s run on the same microcontroller so you can run almost any Flier firmware on any of their ESC’s.

That‘s good news!

Yep good news If you have a good software for it send it to me because I will need it :wink:

I tried with prop under water but goes out of sync. Too much load

What remote are you using? I was having start problems untill I switched to the maytech remote. The firmware doesn’t like the cheap remote that has forward and reverse on the same trigger. That was my experience anyways.

Don’t worry about a little bit of crunchy sound coming from the motor. Mine starts good, but sounds a bit rough / crunchy at low RPM. But, underload that goes away.


Also. Try 14s battery if you can. I wonder if that’s the difference in why mine works so well. :face_with_monocle:


I will try 14s. Different remote I do not have. I do have a ebike throttle with flier conversion board that will make a signal for RC esc. Maybe I can try that. Thanks

I made a mistake. Each time that I installed new firmware I should have gone to default factory settings because what happend was that old parameters were load in the new firmware. I now run 24s boat v31a with 95% start and timing at 5. From zero to full rpm it will go up and down for a bit but then it is OK. With 14s maybe more smooth. 5 pitch cut down prop too less power. Alu 7 1/2 pitch 7 prop 5 kw static trust. Looks OK. Maybe need even more pitch.

That is a very positive message!
So I hope when my batteries are ready and I get my charger, I not must buy a other ESC.
So, I got the information that all’s Firmwares from Flier are running on all ESCs.
So, it can be very helpful and nice from you all when you post the working parameters here?

Testing under load is also different than unloaded. When the motor starts good and runs good and is silent, that is looking great. But when a prop is mounted and running in water, you get a different result. So Testing under load is important.

I open back this topic
USING Flipsky Motor + ESC 400A read box aluminium.

I made several attempt with different firmware.

unfortunately I could not succeed to get my motor running fine. The best I could get is just fex spin…

Does people had better luck ?

My process was :
Updaload Firmware
Reset factory setting
Check factory setting sucessfully applied.
change : 25°timing & Timing On + No reverse
Write setting
Check settin properly applied.

Perfrom the test

I have a excel with some observation…