Electro perturbation in esc

Hello everybody. I need your recommandation with my current problem.
I have some short cut on my motor when it is on charge. I>20 AMPS. It doesn’t come from the remote because I have tested it with potentiometre! Bec maybe but why only with charge?

My settings:
Hobbywing 130amp
Bec 20amp

Any idea?

No one with any idea? for who using the seaking 130a-HV V3 esc. any have the same issue?

I found the problem but still didn’t understand why? I have put a separate power supply with 3 AA batteries to power the water pump instead of connecting it in on the UBEC. And it work. ANY IDEAS?

Maybe a faulty UBEC. Maybe it cant provide enough current for pump, and the 5V drop down or out.
For me, this one works:
€ 4,29 7%OFF | DC-DC Schritt-down Converter 8 v-120 v 96 v 84 v 72 v 60 v 48 v 36 v zu 5 v 9 v 12 v 24 v Buck Spannung Geregelte USB Netzteil AUTO

Thank you for your help. I don’t guess it’s a current issue bcause the UBEC is a 20 amps for a 1 amps pump…

I’m having similar issues… I have two step down converters (5v for the receiver and 12v for the pump) and they both shut off while I ride. I’m assuming they don’t like the current I’m pulling but just like you, my step down converters are rated enough amps to power the receiver and the pump.


Have you try to supply your pump or you receiver with a dedicated power supply? Like me! With 3 AA battery or with a 9v battery?

For me if I supply either the reiciever or the pump with a dedicate way, it work! Try it and tell me what happen!

I haven’t tried it yet since it only happened during my first test on the water but I will definitely do that… Will I fry my receiver with a 9v battery? And will the pump work properly since it’s not 12v?

Receiver must be plug on 5v. so you your bec for receiver and 9v battery for your pump

I don’t have a BEC… I use two seperate step down converters (one 12v and one 5v) and they both shut off under reasonable load (70a) how would you suggest I power the receiver? Maybe a portable phone charger?

Yes good idea. Try to don’t use two step down at the same time to see if it’s electromagnet noise

Yeahh that’s a bummer though because I don’t to rely on another external power source… Do you think two BECs would have the same result?

You need to test I don’t know sorry

I bought a 5V/12V external power bank on Amazon and I use it to power my receiver and water pump! I also have a new remote and now everything looks like it should run smoothly on water. I’m testing it tomorrow! I’ll let you know how it goes!

1 Like

Alright so after doing a second testing session on water it was a decent success. The remote works really well (no intermittent problem like with the last one) even though the cruise control function isn’t that great since it cuts down to zero immediately afterturning it off to regain control of the throttle which causes you to significantly slow down before being able to re-accelerate. The power bank for the receiver and the water pump worked very well so that’s good. However, I still couldn’t fly. The motor wouldstart studdering/shaking at around 12 km/h before cutting off. I wouldn’t be able to restart right away since the output of the bms would get disabled but after restarting it, the same issue would happen at the same speed. Then I decided to bypass the BMSon discharge and the same thing happened except that I could restart right way without resetting anything. I have a 80100 APS 80KV motor with a 7.5in diameter/8in pitch alu prop and a 14S14P li-ion battery pack, flier 400a boat esc and smart 150a BMS. So basically,the main problem is that the motor starts studdering at around 12 km/h before shutting off if more throttle is given. At first, I thought my propeller had too much pitch but then I mounted it backwards to reduce its efficiency and the same problem occurred.Now I’m thinking it might just be a setting on my ESC. Any suggestions? Can it be something else? It spins really well out of the water and it can fly by itself on the water.

What did you set for the Timing in the Flier?

The propeller is quite big especially for 14S

I think the timing is 20 degrees right now!

Maybe 22-25° are better.
And as always the question: Solderjoints all well done and isolated?
Motorwires shortend?

I did cut the motor wires but I was warned of the issue and I solder them very carefully… But it could be the issue. So beside the timing and the solder connection, could it be anything else?

Prop is too much!
6x6 Prop max for 14s.
Timing 25 Grad