Maytech remote v2 - trouble with VESC UART data display

Hi everyone, I am back in the shop putting an efoil together, this time VESC based and with @Peter’s motor. Very promising. More details soon. So I received the v2 remote and I have trouble with the VESC UART communication to display data on the remote (V, A, Temp). If I connect another UART device (my Metr Bluetooth module) to my VESC, data comes accross fine so my VESC UART seems to work. The PWM signal works, I can spin the motor. But I really want to see data on the remote, hope there is just something I am doing wrong.

Here are my settings:

My wiring: 5 wires connected to the receiver from my VESC, circled in red below (PWM, 5V, GRD, RX, TX). No other connections so far:

My VESC Tool Settings:

My Maytech v2 settings on remote:

  1. Thr. Mode Control mode - Surfboard
  2. Batt. Type Main battery type - 3.7V
  3. Batt. Ser Num Main battery Series Number - 12
  4. Pair Pair remote and receiver - done
  5. Calibration Remote throttle calibration - done
  6. Speed Source Speed source - VESC
  7. Motor Poles Motor pole pairs - 6
  8. Wheel Dia. Wheel diameter - NA
  9. Gear Ratio =Wheel pulley/motor pulley - 1
  10. Dist. Unit Distance and Speed unit - km
  11. VESC Thr. VESC throttle control type - None (I tried Current too, I can still spin up the motor but still no other data is displayed, therefore I am wondering if the “current” setting really controls the VESC via UART or still does PWM)

Here is the v2 manual Eileen mailed me.

Did anyone have luck getting UART data across? Any idea what I am doing wrong?

BTW, once I get data on the remote I would really also like to use my Metr bluetooth in parallel to log data. I saw this UART splitter project here. Thoughts?


With most of the display remote , I guess the firmware of the remote need to update to the firmware of the vesc ( same as vesc tool ) and same as any app iOS or Android

You can try to upload a older firmware to the vesc and see if the remote recognize the data …

That is the way I understood things … I hope that help

With the vesc I was able to run several app Bluetooth on my phone st the same things so data info can be sheer I guess …

Update - success reading the data with the 200A VESC prototype I just got from @nickw1881 today. Pretty nice to have all this data on the remote incl. the 2 temperatures. Maybe something is wrong with my other Flipsky VESC.

1 Like

Thanks Alexandre, VESC Firmware Version could be the reason. My Flipsky has the latest 3.62 FW and the other one that now works has 3.58 FW.

Experienced the same.
On older fw it works flawless, but the latest doesnt work.
But I couldn’t find the reason in the vesc code changes.

Hi @pacificmeister, haven’t got the chance to tell yet, but thanks for your awesome work, inspiration, and of course for this awesome forum !

That being said, I wasn’t aware the Maytech remote had this functionality. I might end up getting one now :smile:


8 : pitch - slip :smile:

Page 6 : USB TTL needs to use ( separed buy) to update Fw on receiver , so it is working with 3.58 but not the lastest

I wounder how much it s sold …

looks pretty nice, but still have no clue why it is working with 3.58 and not 3.62

1 Like

Me neither. I downgraded the Flipsky fw to 3.58 and now it works too.

1 Like

Come on guys : @Peter motor , @nickw1881 vesc and Maytech remote ???
What about a waterproof case for the Wand ? :sunglasses: as takuma did for their …

I am so tired of my waterproof cases…


Engineer checked the 3.62 firmware and do some adjustments on remote firmware now. It can work with 3.62 firmware now. Later we will make some updatebox for remote and receiver firmware updating.

Hi guys. Having the same issue trying to get the Maytech remote to receive data from my flipsky vesc. This is my first VESC so admittedly im a bit of a noob.

I am running the latest version of VESC tool (2.02). Apparently, with this new software it has been requiring me to update the firmware on the vesc in order to make it through the controller configuration wizard.

I was reading above that you guys got it to work using older firmware. I was wondering where you get the older firmware from? Also, if the latest VESC tool doesnt work with this firmware, does anyone know where I can get the older VESC tool version?

Lastly, I have heard some others say that the TX and RX wires on the maytech receiver might be backwards from the vesc and that could be the issue. Anyone else run into this?

Thanks for the help!

UPDATE: Got it running! All I had to do was flip the TX and RX wires on the little jst connector. Rx from the VESC needs to go to the TX off the receiver. Makes total sense and is also laid out like that in the wiring diagram for the maytech receiver. Easy to mix up though depending on what connectors you end up using. Like i said I had to flip the pins on my jst connector.

This is so cool though. Great that it seems to work with the latest VESC tool and firmware too!

1 Like

@Jsonnett Do you mind posting a picture of the wiring setup? I am about to do the same but want to double check I get it right!

1 Like

I have the 75/300 VESC and Maytech V2. Will someone please confirm that I only need to connect these 5 wires? If I understand correctly, the RPM and Battery Voltage will communicate through the RX, TX and therefore I don’t need to connect a motor wire or a battery wire.

What version firmware were you using to get the Maytech working?

I just ordered a Maytech remote, I believe V2? Will this work with current VESC firmware versions?

Hi, yes, it can work with official VESC firmware.