Motor ? Flipsky Vesc problem ? Help needed to surf again

Hello guys,

I’m Léo, 24. I have finished my build 2 weeks ago. I’m in holidays in Croatia to test my build BUT after 2 session it’s not working anymore.

I had a lot of problem to program the Flipsky VESC 200A but can’t explain why. It was a nightmare. I lost 2 times the vesc configuration without any reason so I had to re-program it.

On my build, I have a magnetic cut circuit. So every time I fell off the board the circuit is cut till I replugged the magnet.
But one time during a ride, the motor made a weird sound then didn’t want to turn anymore or weirdly like if one phase was missing. Configuration lost again…

My build;
12S9P Molicel P42A
Flipsky VESC & remote
Flipsky 100kV filled with corrosion X
FR prop 7"

I tried to reprogram it, using the wizard in BLDC first, then in FOC.
It doesn’t work at all. I changed current, D, or even rpm. The motor doesn’t turn anymore.

In FOC mode:

Résistance is really high
“Flux linkage can’t be measured”

I tested the three phases of the motor, it seems ok… Flash the vesc… reprogram the protect parameters, current, voltage… Changed the duty cycle to 99%.
I don’t know what to do more I’m depressed.

Picture & video below of what is happening:

Does the motor detection still work? I think it is not good to cut off the motor during heavy load like you do. This destroyed also one of my 200A 60V Flipsky VESC


It didn’t work these two previous days, I will try again tonight. Jeff M, a French builder did the same wiring on his different builds and he told he never had a problem with it…

I have a kilovac contactor linked to the magnetic cut circuit.

In addition, to make it work, I always had to switch on the remote first, unlock it, then switch on the vesc.

I did the contrary few times and that’s how I lost the vesc cobfiguration. That’s what happened 2 days ago in the water…

I just tried to downgrade there firmware as I had the latest version, but same error message “flux linkage detection failed”

I made some research on forums:
Here are all the advice I found facing such a problem:

Voltage cut
Instal bootlmoader
Then reinstall the firmware
Remove uart receiver during detection
Changing phase order
You should reinstall firmware on the vescs and do the motor detection WITHOUT the remote plugged in. That should work…then plug in the reciever to ppm, and start calibrating the remote.
Charge the battery
This error seems to come up when you make changes to the setup. In my case it was changing from a 12S1P to a 8S2P battery. Just press the read default motor configuration and then write motor configuration and the exact same for the app. All found on the far left hand side of the Vesc PC tool. This basically wipes absolutely all of your old settings. Now you’re ready for a fresh start with Auto Detection in the Setup Motors FOC tab.

If you have other ideas… I will test tonight and give a feedback

Unfortunately,I could see disconnecting the battery under load might take out the vesc especially if it was a 12s max vesc (using a 12s battery) and braking was turned on in the vesc.

Here is someone with a similiar issue:

Thank you I will take a look. The Vesc is normally rated for 60V… I’m at 12s.
I asked Flipsky about it il waiting for a feedback.
However I think the VESC has died and I’m good for buying another one :confused:

Update: I have tried with another new Flipsky VESC: same issue

  • I can measure 6 Ohm 6 Ohm and 12 Ohm between the phases (it seems there is a problem!?)
  • R measured by vesctool is really high
  • i have filled my motor with corrosion X. But it leaks from the cable side ! (we fill the corrosion x on shaft side)

What do you think…?


If corrosion X can find its way out saltwater can find its way in… I would open it up to make sure there is no saltwater mixed with the corrosion X and inspect for any damage on magnet/coil, check bearings ect. Once motor is runing you will have to fix this leak too.

It is possible that this is the main cause of the seal damage! There are three reasons for this:

You have right… Job that seems not to be easy

thanks for these links. Some months ago I’ve seen that filling motor with corrosion X was almost an obligation. I wasn’t aware of these potential issue…

I think we need to separate. Trampa is not referring to a motor but to his VESC. The thermal pad is for sure a more complex material than the rubber seal.

The corrosion prevention ability shown in the comparison is for a stress test. I use the corrosionx just to “catch” single drops of water, wherever it came from. If your motor is full of (salt)water there might be a bigger issue :slight_smile:

I am driving two motors filled with corrosionx hd, both still work fine. I don’t want to promote this particular brand but rather the idea of using such component. You can always contact the supplier and ask for compatibility

1 Like

I’m dumb as f****

The problem came from a bad soldering between my extension phase cable and my VESC.

It was in front of my eyes since the beginning.

Anyway it works. THANKS FOR YOUR HELP! Now i can finally begin efoil :joy:

Cool! I would still take care of this leak…

1 Like