Telemetry not working with Flipsky VX3 Remote

Hi there,

sorry for creating a new post, but I don’t think anyone experienced the same problem as me.
My problem is, that I don’t get any telemetry shown in my VX3, although I connected the receiver via UART and the motor works and spins fine. I read through all the other posts of other people, having seemingly the same problem, but there problem was always, that they connected the reveiver through ppm instead of UART.
I even tried switching the rx and tx-wires, which resulted in the motor not spinning any more.
I am using the Flipsky FSESC 75200 Pro as an ESC.

I might just have missed some kind of setting.

Thanks in advance.

In the remote in the left upper corner there is shown “RP” which should only get shown when connected via ppm, instead of “RU” for UART.

Hi @maninjo, I have this exact setup with VX3 and the Flipsky 75200 pro (and it currently works in UART mode). I don’t have my hardware available at the moment to go looking at stuff, but I did notice one odd thing in your second photo showing the receiver plugged into vesc. You are using a 4 wire connector cable (green/orange/black/red). I cannot tell you which cable I am using, but it is not that one. I have that exact connector sitting in the VX3 box along with the PPM cable. So you might want to try a different connector? There are several connectors that came with the VX3 (of course all unlabeled with poor instructions!)

Also, FYI, since you have the 75200 pro version, it has bluetooth built in. You can get the VESC app for iOS (or android I think) and connect directly to the vesc to adjust settings. You can also use the VESC app to log data if you bring a phone with you can keep it connected.


Thanks @S_Roger.
These are all the cables I have. There is no option to connect the receiver directly to the ESC.

These are all the cables that came with the ESC.

And these came with the remote.

I have to use one cable that came with the ESC and one that came with the receiver. No other cable fits and a direkt connection is not possible.
With this option the “rx” from the receiver goes to the “rx” of the esc and the same for the “tx”. The motor spins but I don’t get telemetry.
The receiver is powered from the 5V to the esc.

This is another option I found to connect receiver and esc. But the motor won’t spin because “rx” from receiver goes to “tx” from esc.
With this cable the receiver also only gets supplied by 3,3V, which is enough but 5V is better I suppose…

Maybe I lost a cable, but as long as “tx” and “rx” are connected the type of connection should not play a role…

I installed the vesc-app and used it already. But I still use the laptop to set up the main settings because I find it more intuitive on the big screen.

You need the cable like this pic. Set in uart mode in vesc. When working it will show RU and not RP on the vx3.

1 Like

I’ll have to open up my esc box later to get a look at what I have in there (if you don’t figure it out first). I did use one of the cables that came with the VX3 and then connected that to the esc with an additional cable like you have shown above.
One other thing to check, is your VX3 itself set to VESC mode? There’s also FSEC and non-VESC modes for the VX3.

Thanks, I am using that cable.
I have set it to UART mode in the VESC but it still shows RP. …

I tried all the modes, no luck.

Th cable you show in the picture is not the same as the one I have. The orange and green are swapped. I have that cable too and it does not work.

This must be the correct one, I used it already. But I will try again and verify the settings in the VESC-app.

It was set to UART and I saved it again, still “RP” in the remote and no Telemetry. Motor still spins when I give throttle.

Do I have to change something else in the VESC-Tool? I could not find where to set it to UART in the phone app, I only found it in the Computer tool. But I guess it should not make a difference where I change it.

I think in the phone app its under muiltisettings.
Anyway thats the cable that works for my 75200 non pro version. I can’t think of anything else except in my vx3 it is set to vesc. I got stuck in this loop before and I am not 100% sure why it did RP as well. I set mine in ppm first then with the ppm cable. Then went to uart and bam telemetry and RU

Okay I dragged my mast/motor/esc up from the garage and plugged it in to check VESC settings. The only difference I spotted is with “UVCAN raw throttle mode”. I have “current no reverse brake”. Not sure if this would cause your connection issue though.
Also, added an image of the two cables I am using connecting receiver to VESC

Weird, under multisettings I only have “general, Limits, FOC and BMS” nothing else…

Thanks for the effort. I am using the same cable and I have set the remote to “VESC”.

I set it to the same now, did not change anything.

Thanks for the help anyways. I will try to connect it via ppm later this evening and then change it to part again. Maybe this will help.

Hope you can figure it out. Maybe re-pair the VX3 or unplugging and reconnecting can convince the receiver/vesc to behave.
If it’s any consolation, I rarely find myself looking at the telemetry while I am riding (or just trying not to fall) and I just check the logs after to see how power, temperature and voltage were. I will probably switch over to a Bremote at some point because it seems to have “geared” power levels which sound nice.

1 Like

I just looked at the android app connected via BT and I don’t see any place for uart or ppm either. I did that on the windows app. The android app has less but at least allows current and voltage limit changes which is good at the beach while you are getting things fine tuned.