VESC Cutting Flipsky 75200

Hi folks I have built an efoil with a Flipsky 75200 VESC 6561 motor and and LG 10S11P 2070 battery. I am having an issue with the VESC cutting out on the water aroun 80 to 90A. The battery is above suspicion several people on the forum have the same battery and it’s fine. The VESC is not getting hot the remote report 25C max. I tought it was my BMS so I added a nother wire and connected everything direct no BMS but smae results. It must be my settings. Here are my settings if anyone can spot something I did wrong.








Increase absolute maximum current to 250, and make the slow on maximum current true.

Also use profiles to limit the max power. 5-6000W should be fine and will a more even response over the battery voltage. This is shown as maximum wattage in your screen shots.

2 Likes

Thanks for the suggestion isn’t that dangerous given the VESC is rated 200A the watts limit is already way above the 6000 watts the motor is rated.

I ran those settings with an aircooled 75200 for 12 months on a tow boogie. It only died when water got into the case.

What’s happen is that it’s probably spiking above 200Amps and because slow absolute limit limits isn’t enabled it will immediately shut off.

I like to set the battery specs to the maximum that the battery can take.

Then set the current to the maximum that the vesc can take.

Then use power/ wattage limits and the vesc will work with in the hardware limits set above to give a consistent output as the voltage changes.

I use the IOS version of Vesctools so I’m not sure where you make changes

After the initial motor config wizard was complete I had to change a few things and only these things. I find these under “Multi settings” “Limits”

I set Motor Current max to 180

I can’t remember if I changed Battery Current Max but mine is 250

My Battery Voltage Cutoff Start is 32
Battery Voltage Cutoff End is 31

I changed Battery info under Motor CFG - Additional Info to 10 Battery Cells Series.

Under App CFG I changed App to Use to UART

In iOS, click profiles at the top, then add new profile, enable power limit.

But recommend using the desktop version for set up. Lots easier and less likely to make mistakes.

2 Likes

200A motor current max is a lot, motor will be in saturation.
You could try lowering motor current or adding saturation compensation in the VESC settings. Can’t remember the parameter name though.

I have same setup and use 150amps max but I have maximum watts set to 4000.

Can you run vesctool live with BT and record a session?

When it cuts out do you have lots of throttle left?

Thanks everyone I tried the foil today it’s good now. I changed 2 settings and it’s fine. I set the watts to 5000 and max amps to 250. My theory the watts limit was only accepting the first 4 digits so it was limiting it to 1500 watts. I set to 5000 and it’s fine it uses about 100A max. Now I just have to learn to ride such a small board. I have been kitefoiling for years on a tiny 13L board but this is something else you don’t have a kite to hold on to and you can’t waterstart and get up at the same time… I have some learning to do!

3 Likes

Glad it’s working! I still need to finish setting up this same battery myself. I’ll be bookmarking this thread for later when I update the VESC!

Great that it’s working. I am curious about the logic of the 250A setting. Higher than necessary?

Most of the problem I think was “slow abs current” false. So any spike above 200, even for a ms would stop the motor. Changing this to true and increasing to 250 would have fixed it.

The 250A is phase current so is more than battery current.

1 Like

There is a difference between Maximum Motor current and Absolute Maximum current.

Maximum Motor current is what the VESC will try to regulate to. However, as no control algorithm is perfect, the actual current may peak above that value from time to time, only for a fraction of a second.

That’s where Absolute Maximum current comes in. This one is intended to safeguard the hardware. It monitors the current and as soon as it sees a value above the set one, it will disable the motor and go into fail state, until you let go of the throttle completely to “reset” this failure state. You can set the slow… option to make it a little less sensitive.

In general, Absolute Maximum should be set 30-50% higher than Motor current max.

All the other settings (Max power,…) will also only soft-limit the motor, like the maximum Motor current value.

But if the motor completely stops and needs to be reset, one of the only sources regarding current is the “absolute maximum current” setting

2 Likes

Strongarm suggested that so I gave it a try. From what I can see on the remote the current barely goes above 100A at full power so I don’t think it will ever get close to 200A with a 36V battery.

1 Like

I find the whole Vesc Tools thing a bit intimidating as there is very little documentation on what the settings do and how they interact. I managed to get mine functional and took the old if it’s not broken don’t fix it approach. :grinning:

I believe @Strongarm suggested 250 for ABSOLUTE max. Is that what you changed to 250?

I just set the motor current to 180 as it was a bit higher than what I had for the 12S battery I had before the robot pack.

I just checked what my ABSOLUTE is and it is 350. I also did not change anything with Watt values either so maybe I’ve been lucky.

At the 30-50% less than Max at 250 for
Motor it would be 175 - 125. I don’t think I need 180 so I will likely lower it.

As you say I don’t see any value over 100 in the log files I have so shouldn’t be a problem.

There is a setting within Motor whose name is Slow ABS Current limit that shows ON in my setup. This is what the Help screen says about it. I assume this is what Mark mentioned. This was already ON from initial motor wizard step so it would seem odd if yours was OFF.

If you use the desktop version of vesc tool, there are some explanations of parameters. You also get a better view of the structure of the tool. There are videos that explain how vesc tool works. It is not the easiest tool Iworked with and it might take some time to figure the right paramters for your setup. Max current is meant to protect your motor from burning, absolute max to protect the FETs in your vesc but still allow some short spikes. If you hit abs max current often, some of your other parameters might be off.

1 Like