VESC setting for FR motor

Hey guys,

Can someone post his VESC setting running the FR motor FOC? I’m using the MakerX 75200.

I had no issue by the past getting the flipsky 120kv to run with the flipsky 200A vesc.

With the FR and 75200 vesc, I can’t get past 41% duty cycle under load (maxing arround 60A). If I get the motor to start spining out of water then drop it in I get 95% duty cycle 106A. It seems the motor for some reason can’t get to higher current underload.

I ran the large inruner wizard, use current control, no reverse. Max current set at 160A, battery max current at 250A. ERPM 65000

Free spining motor get up to to 7350rpm at 56.5v so it is bang on 130kv.

I tired to disable decoupling, no change

If I calculate the flux linkage based on 130kv it doesn’t match the value in vesc tool, it should be more like 5.3mWb


Uploading: 20210926_135819.jpg…
Processing: 20210926_135759.jpg…
Processing: 20210926_135741.jpg…
Processing: 20210926_135735.jpg…
Processing: 20210926_135729.jpg…
Processing: 20210926_135724.jpg…
Processing: 20210926_135717.jpg…
Processing: 20210926_135712.jpg…
Processing: 20210926_135654.jpg…

1 Like

hey Manu, your foil looks ultra dope ! do you have a build log ? how big is the mast? would you recommend more than 75cm mast size? why did you get an ozone foil instead of a (cheap) gong?

is your mast detachable?

Thanks, I work for Ozone that’s why :laughing: I will post a build later when I have a bit more time. But yes mast can be unmounted ect. Still few things to finish/polish, battery enclosure ect.


What type of seal do you use for the hatch?
Your motor pole number is 16 :thinking::thinking:

a super soft silicone from smooth on, 10-30 shore.
Yes the FR motor is 16 poles if I’m correct.

Let’s stick to the issue please, I will creat a build post :slight_smile:

1 Like

On the forum on search :
My settings

Not all pics shows but what I see it looks correct

Try duty cycle mode maybe …

Thanks Alexandre, changing the flux linkage to 6.125 as calculated made the motor sound much better free spinning I will test in the water hopefully it was the issue and test your setting too

1 Like

Just to be sure. With the board on the warf not moving and prop in the water, if I push full throttle I should get 95% cycle duty correct? I tested again playing with settings, I can only get 46% duty cycle for 156A motor.

Static test ( no other limits ) : duty control mode : you should get 95%

Static test : current control mode : you get % of the max setting of the battery that the vesc use so the motor gets what it needs ( no other limits reached : max motor amp …)

So by setting your battery max amp at 200A and if the vesc needs only 100A to keep the motor running at its full erpm ( and you can check ) for a given prop : you should see only 50% and it’s correct

I didn’t test control mode that much , but that is about how it works , so you might not have a problem here

46% of 250= 115A battery for 136A motor , looks correct to me with some prop « cavitation »

So this could be correct? Erpm looks low

Tried the efoil with the old 300A opto seal and worked perfect …

1 Like

I have to check with erpm vs poles but you have max out the limit set on motor max amp : 178,4 for 160 set so the rpm will be limited anyway

Amp motor will allows be higher than battery , so better setting would be 200A for the motor and 180A

Motor for start , kicks… , battery for speed , for high speed both high

130A motor , 90A battery gave me a good start and 35-38km/h with my setting at the time

1 Like

Sweet will give it another go tomorrow with the vesc

Might be wrong but regarding your rpm or erpm , 16 poles so 8 pairs : erpm not 17240 but 34480 so rpm 34480 / 8 = 4310 for a possible of 53v x ,95 x 130kv = 6545

Hitting 66% of max rpm with motor max amp on at 170A on static test looks ok to me

But if your settings are right , the erpm is indeed low probably because as soon as you hit the setting motor max amp ( start or pull the trigger fast) , the motor rpm will get stuck at this value ( annoying ) to overcome this , I regulated with a lower battery max amp setting to fit my needs of top speed

That why I set motor max amp high than battery and I do my test with duty ( voltage) control checking erpm ( with no setting on nb of poles ) , like your old esc

Many way use vesc , just try what best work :sweat_smile:

What I would try :
Motor max amp : 150A
Battery max amp : 110A ( always 30-40 lower)
Do a run , check % of duty and your speed riding
If you are to slow , and get 95% , add 20A and so on ( first on battery , than both …)

Never tried past 40km/h so no idea what amp for the motor is needing

Thanks for the help Alexandre, I’m getting 59000rpm free spining so pole count setting is right. I will try tomorrow to set battery current lower as you suggested.

Success!!! Sep 27, 2021 - | CkrxX

I set battery current at 150A and motor current at 200A. I had an ABS overcurrent fault at the end of the session, it happened trying to go from 0 to full trottle, not to sure why overwise it felt really good.

There is also a parameter called “Absolute maximum current”.You can set this a bit higher than the “Max motor current”, 220 or 230A if max motor current is 200A.
With a 63100 Outrunner, these settings work for me:
Motor current max 150A
Battery current max 100A
Absolute maximum current 180A


get use to the data and adjust settings, abs fault: motor want over 230A, as said always allow +30A on this value
for me motor max amp doesn’t need to be that high (since you are around 130A for 40km/h…), and you can add time on the ramping setting of the remote to overcome pics when you pull trigger fast

I supposed it s the 7’’ Fr prop ? ( 8% slip)

I tried 180A motor and 150A battery and it didn’t work for some reason… What’s your ramping setting?

0,9ms if i recall correctly