VESC Setup Help Please!

So I just got my batteries, esc, and motor hooked up. I set up the motor using the VESC tool, and everything was looking good. Then, the tool said I had to update my firmware if I wanted to set up an input. I went to firmware, and the only option was 75_300_R2, so I used it. Then I reran the motor config, and now my motor jitters and heats up instead of turning smoothly. My motor is the flipsky 65161 and my esc is the flipsky 75200. I bought them together here.

Can anyone give me any advice? I don’t know what to do now. Is there a way to reset the firmware on my esc so I can at least determine what component is causing the issue?

Edit: I can post a video of the motor if it would be any use.

To what version did you update? If it is fw 5.3 you need to switch off hw filters. I also had difficulties with the motor wizzard, it did not determine the correct motor parameters with FW 5.3. Manual Motor detection worked, as well as buit in Motor detection of the metr.at app (requires a metr BT module).
You can also downgrade to the version you had before if you use the right version of vesc tool, see here: Precompiled VESC Tool Archive - The Citadel - Essential References for Esk8 - esk8.news forums

Use 2.06 if you want to downgrade to FW5.1, 3.0 for FW5.2.
5.1 works well for me on a similar HW(makerX Hi200).

2 Likes

So it sounds like I could either disable phase filtering, or reflash an older version of the hardware. What would you recommend I do? (I just installed vesc 2.06 and I don’t see any filter option, so I assume it souldn’t matter for the older version)

Up to you, both should work, I havent tried 5.3 under load. 5.1 (comes with vesc tool 2.0.6) works well for me and others. Some people had problems with 5.2, motor stopped at high current. You need to relaunch the wizzard after the downgrade. FW < 5.3 has no phase filter support, so nothing to switch of. One limmitation of 5.1 might be lack of support of the second uart port. This would be needed to connect a metr.at pro and a remote with serial connection at the same time.

2 Likes

Dude you’re a godsend. I’m building an efoil for a school project and this part was due in fewer than 10 hours. The fix was perfect. The motor doesn’t overheat, and it responds perfectly to the remote. I’ll probably have to do some fine-tuning, but it’s now working. Thank you so much.

I’ve been having this problem for a while now and not able to get my motor working, and this thread solved it. Thanks!

Nice! Glad you found the solution!

@Malveymonster

What option did you chose? 5.3 or downgrade?

Best
Christof

PS
I am setting up the same electronics.

Sorry it took me a while to respond. I used the downgraded version of the software because there were fewer things to mess up. I just started with the firmware upload (which was technically a downgrade) and then ran motor config and input config. That’s all it took for the electronics to work. I still am doing a bit of searching to see if there are better settings to use, but I’ll probably use as is for my tests.

Thanks.

I updated to 5.3 and it seems to work. I tested under load in a water basin.

I will soon share the parameters.

Best
Christof


12x12 2600mAh
VX3
Flipsky 75200 & 65161

1 Like