VESC Tool - "R is 0" Error

Hey guys, relatively new to the VESC Tool. I’m running a MP70131 Motor with a Flipsky 200A FSESC. I’m plodding along nicely until I get the dreaded “R is 0” Error and now I’m stuck!.

Parameters I put in are:

  • Motor Current Max: 120A - as it won’t let me pick anythig higher - Motor can take 170A
  • Motor Current Max Break: 0A
  • Battery Max Current: 79A
  • Battery Max Current Break: 0A

I’ve set the voltage limits to:

  • Battery Voltage Cutoff Start: 47.6V
  • Battery Voltage Cutoff End: 43.4V

Its mapped the PPM signal from teh remote no issues and updated firmware to FSESC but as for the motor I can’t get past this and no amount of google is solving the problem so I said I’d ask ye guys!

Has anyone come across this and managed to get this resolved?

Didn’t see this issue in any thread so started a new one - apologies if I missed something

These are the 2 errors that i’m experiencing depending on which way I go about trying to set up the motor:

I’ve tried swopping all the phase wiresand re-running the test but to no avail. I’ve tried moving the motor by hand and again there doesn’t seem to be any issue in that regard so i’m stumped.

Ok will try to help if I can ( I do have my setup with me …) but ,

  • set lower max limits ( you can change this after detection anyway )
  • you can run detection directly on motor page without going thought all
  • on your first screen shot is already value , you tried to run the motor with those values ?
  • your battery setting is the one you are using for detection because lower voltage will cut everything and stop detection

I had a problem one day with detection after a update , I had to reload the old motor setting that I saved I order to run the motor once than detection worked

Another way would to try with a values from a other motor 65151 or FL just to get it started maybe

If anyone has a better idea? These is my FR motor setting , try to enter this numbers to vesctool , save them (apply) to vesc , them try detection again

1 Like

I will try tomorrow and let you know how I get on!!! Really appreciate it!

Ya I now see i can just run the test from the FOC section so I don’t need to keep repeating the steps - thanks, saving some time but still the same problem.

Tried with those settings -

and still no joy - error: “R is 0”

Setting loaded on vesctool and apply ( M on top right on your screen , not Apply on the bottom ) in the vesc ? ( just asking because at beginning … set apply save …)

No voltage cut , sure of that ?

Are you able to run the motor at all using the my setting or blc mode ?

Ya I’m happy that I’m pressing M in the top right of the screen.
Currently trying the Motor Wizard, selected BLDC and the below limits

Then set the battery limits followed by selecting sensorless - I then get the gree MC Updated Logo down the bottom right and I go to run and the following happens:

So unfortunatly, I can’t even get BLDC to turn the motor

Well , problem with motor or vesctool

Can you try to run the motor in foc with FR setting?
Can you another motor to test detection

Things that I have done a couple time : erase everything for pc , drivers, folder , and re install all vesctool (older firmware )

Tried again my friend and no luck. So I did a bit more digging and the VESC Tool has a Error Terminal.

When I use the Setup Motors FOC Wizard I get the “Detection Failed. Reason: Sensor detection failed” Erros and the Terminal states:

When I use the Motor Settings - Motor Setup Wizard - FOC I get the “R is 0. Please measure it first.” Error and the Terminal states the exact same error.

When I use the Motor Settings - motor Setup Wizard - BLDC I get the Error:

adn the Terminal says the exact same error. Now the Flipsky 200A FSESC is supposed to be rated for 60V and I’ve a fully charged 14S battery. So now I’m going to go away and reduce the battery to 12S and try and re-run and I’ll give an update late tonight. Thanks a million for your help so far!

So before I changed my battery I decided to take a look at the settings more. In the Motor Settings under General - Advanced the Max Voltage Input was limited to 57V but I have a fully charged pack so I’m closer to the 58V. Changing this to 59V and away she works!

Thanks for all the help! I’m sure I’ll be back with some more queries before this is all over!

Man, we said many times on the forum the flipsky won’t handle this voltage. Flipsky 200A vesc based is basically a vesc 6 MK3 watercooled. It won’t handle spikes above 60V, 12S is safe while 14S will most likely burn your ESC. You have been warned…

1 Like

Good job , yes voltage cut ! I was thinking lower value not the higher but yes these safety cut everything …

Can we have a screen shot of the value for this motor please ?

Ill screen shot everything once I get the motor running smooth but I’ve the cut off at 59V which let me get past all the errors above. Any lower and it failed

Wow, 14S with that VESC!? You’re a brave soul! Best of luck!

Let us know how things work out using 14S.

What Control Type did you select for PPM Configuration?

@tylerclark - brave indeed - I know I’m pushing it but its worth a try!
@MAC - I’ll be posting an update as I go. So far I need to get the throttle working better. I’ve it set to Nautral but its a disaster at present so I’ll need a few more hours over the coming days to iorn that out as I’m still learning myself

Did you email Flipsky and ask about running on 14s? I did. They told me it will fry. What makes you decide to do this anyways? And then you even fully charged your battery?! At least stop charge at 4.0 volts per cell / 56v!

I have my fingers crossed for you, but I predict it will fry on the first test under load. :crossed_fingers:


I’m just learning. I have been trying “Current No Reverse” That is strange because the motor either runs at full blast, or nothing. I read that is how it works. I guess I need to apply a actual load to the motor. PID speed control gave me the most normal seaming speed control.
I see Tylerclark is also working on learning the VESC. So guys I will let you know what I learn.

1 Like

Mine seems to work well on FOC. Below are the settings I get after running through the motor setup wizard:

82 is pretty high for the resistance ! It depends on wires and plugs as well , but for most inrunner I tested I was around 30 …

If I am correct running this motor at 100A , means 820w of heat on the system to cool , I don’t know if it is even possible with water …