VESC with folding prop. Motor won't start back up untill very slow speed

Hi guys.

This question is to the guys with VESC knowledge.

I’ve been learning to surf my e-foil board with the folding prop. I’m finally getting it!

Now that my skills have progressed I’m noticing that once the prop folds and the motor stops spinning, the motor won’t start back up untill the board has decreased to a very slow speed. I would guess 3-5mph. The motor is not spinning when the prop is folded.

After a week or so of tweaking various settings I plugged my PC in and noticed settings referring to inertia reference, pitch, and angle. I’m starting to think that there is some sort of safety feature built into the VESC that prevents the motor from starting untill the board comes to a stop.

I’ve played with all the VESC settings. But, I have to admit that my understanding of the VESC is extremely limited. My primary method of editing the VESC settings is my Android phone. But, if I open the aluminum box and plug in the USB cable I can connect to my Windows PC. Is there a way to connect to the PC with Bluetooth? It’s a pain in the ass to have to open the Aluminum box and plug in a USB cable.

Any help would be much appreciated.


There’s no way the motor could be spinning with the blades closed and they are only opening once you are slow enough?

1 Like


I can hear when the motor is spinning, or trying to spin. Yea, It just does nothing untill I get down to a super slow speed, then the motor starts up fine. It’s driving me crazy.

When the prop is folded the motor stops. I don’t understand the relationship to speed. The 75/300 VESC doesn’t have a IMU built in does it?

So, there is no way the VESC would know the board is still moving right?

Same in air and in water ?
Yes the vesc knows it is moving , what it does why that i don’t know
May be the delay in open/closed loop start up ?
Better asking Benjamin on the vesc forum ( got my answer to my problem last year and firmware updated pretty fast )

Very good question , probably the first time it happens , moving without any back emf …

1 Like

Are you in current control mode or duty cycle mode? Maybe the prop starts spinning backwards slowly when folded making the VESC struggle to start it, in this case you could increase the open loop current. Just my thoughts…


i haven’t log much regenerated courrent with the FR moteur and classic prop, i don’t think the folded prop would turn much
but yes from a folded position to unfold at mid speed this may needs more current for start up than still start and low speed, at least on the first 100 erpm

worth maybe to see the difference between duty vs current control

1 Like

Thx guys. Keep the ideas coming. I’ll post the question on the VESC forum.

I haven’t thought to test it in the air. I’ll try to do that by putting it in the car and driving around. Good idea.

I found duty mode works better then current mode. In current mode it doesn’t come back untill I’ve fallen. In duty mode it will come back just before I slow down enough I sink.

I’ll do some more testing and keep you guys posted.

Here’s my ride yesterday. Sorry, forgot the camera.


Another option could be to adjust the settings so the motor brakes when you release the throttle. You wouldn’t do this with a non folding prop, but it would prevent the motor turning too much wile coasting and even make the board a but safer for if you fall. once you press the throttle again after coasting the motor will start spinning like it should.

How do I do that? That sounds like a good idea if the problem is the motor slowly turning backwards when the prop is folded.

Thx guys. You’ve given me some stuff to test and work on.

Is the a really good cheat sheet / instruction manual detailing all the VESC program options and settings, and what each setting does?


In ‘app settings’ you’ll have to set it to ‘current no reverse with brake’ and set around -60 amp motor and -10a battery currents in the motor current limits so it actually can brake. Then after that I’m pretty sure you adjust something else in the app settings and it should start doing it :joy: it’s been a while since I’ve done it, but with a bit of fiddling you’ll quickly sort it.

I haven’t found a great VESC tutorial but a bit navigating around the settings usually works for me. Looks like you’ve got your efoil going well and a good location to ride!

Thx I’ll try that. Do you know if this VESC can connect to a PC with Bluetooth, or do I have to use the USB cable to connect?

The Bluetooth works good with my Android phone, but it looks like not all of the settings can be edited with the Android APP.


I don’t think you can connect PC wirelessly. But all the settings you need can be accessed by the app on Android.


I hooked up a drill Chuck to the motor shaft and spun the motor slowly in reverse and pulled the throttle, and guess what…the motor didn’t start.

So, I’m thinking that the folding prop is spinning the motor slowly in reverse when the prop is folded and that’s why it won’t start.

I changed the VESC settings to “Current No Reverse with Brake”. And I set the motor and battery brake currents pretty high. But, when I turn the shaft it doesn’t feel like it’s braking.

Wouldn’t you have to hit a brake button, or change some other settings to tell it to automatically brake when the throttle isn’t being pulled?

I feel like I’m making some progress…


Nah, there is no immobility lock or something, also the IMU is just for orientation (it has no reference), not for position/speed (therefore you need a GPS).

Sure, just connect to the VESC via bluetooth to your phone and then go in the VESC-Tool app and go to developers and activate TCP-Bridge.
Join the same wifi network with your PC (maybe open a hotspot with your phone if you are at the beach) and connect on the PC VESC-Tool to the TCP address of your phone.

In short: VESC - (BT) > Phone - (Wifi) > PC

In general no: when rolling backwards with my esk8, I can still spin the motor forward to start running forward.
I guess it is a setting thing (like you prohibit negative rpm or something).
Still without your settings and a real log of your VESC telemetry I doubt anyone can answer this.


Thx for making a solid effort to help despite the limited information I’ve provided.

After putting my electric drill on the motor shaft and spinning the motor backwards slowly, I did notice the motor wouldn’t start. I’m not sure the prop is spinning the motor backwards when folded, but looking at the prop it does look possible.

I went through all the VESC settings. I found one called “Start Boost” I think it was called. It was default at 0.1 and I changed it to 1.0. That seemed to help.

I also changed the throttle setting to Current No Reverse with Brake. Hopefully that will brake the prop and help keep it from spinning when folded?

After those changes I put the drill back on the shaft and tested it again. The motor started every time. I tried various speeds in reverse. It was still starting up extremely well.

I plan to efoil on Friday. I’ll let you guys know if that fixed it.

Thx for the ideas guys.


That TCP-Bridge trick sounds amazing. I’m gonna try that. Thx.

Do you know if you can do firmware updates that way? That’s the only other reason I can think of where I’d have to open the aluminum box and plug in a cable.


1 Like

Very interesting
You set current no reverse with brake and still use duty control ?
I always alloyed some négatif current flow from the motor like -20A and the same for the battery

Boost start is it still a option when running FOC mode ?

You can also rework the mid point of the throttle curve to set it in a « Reverse-brake« zone may be
So the motor stop for sure when you let go the trigger (?) or may be what it does in no berbères with brake…

1 Like

Sure, you got full control like if it was directly plugged in via USB, actually the VESC handles all inputs the same, no matter if it is USB, UART or CAN, they get translated to universal COMM inside. Only difference is, that on VESC without permanent Bluetooth (like the earlier vesc6 versions) you can fuck up when you disable bluetooth during the setup.

1 Like

How do I rework the throttle curve?

I’m super confused about whether or not I’m using FOC or not. I think I am. How do I capture and share my settings? If I figure that out, I’ll post them.

Yes, Duty control was working better then current control. But, if these changes fixed the starting issues, I’ll try Current control. I can change that in the remote while out on the water.

I think the issue with current control was when catching a wave there was no load on the motor, so partial throttle it seemed the motor would just stop on me. Then wouldn’t restart.


you can use:
file, save configuration motor, app xlm , you can share the xlm file

for motor mode:

motor settings, general , general, motor type: bldc, foc…

for the throttle curve:

app settings, PPM, mapping, pulselength center value (around 1.500ms) you can try to change this value so that when you let go the trigger, the center is offset a little on reverse, but this isn’t a “nice” way to deal with the problem

always make a folder with saved conf xml with mod so you can upload them after, and as usual: read, save, mod , apply, save, check with RT logging

try some settings that would make harder to turn the motor shaft backward…

1 Like