VESC6 + 80100 troubleshooting

Hi folks,

I’m quite desperate running my new 80100 motor with the trampa VESC6+ controller.

The default vesc6 firmware is limited by software to a max motor current of 120A. Unfortunately that is not enough to get on plane for me (80kg, RL-wing, good working propeller, 80l board volume).

That’s why I needed to flash the VESC with the no hw limits firmware to adjust the motor current to a higher value than 120A. I’m now facing the problem that exactly above 100A the motors begins to get out of sync.

(motor current limit : 120A, battery current limit 80A, abs over current 150A, all other limits are set high)

The strange thing is that it will get out of sync exactly above 100A (99A,100A is fine). I tried to the following to fix the issue without success:

  1. run the motor detection again (again with 750g outrunner motor, because Benjamin Vedder told in a video to handle the 2kg 80100 motor as a 750g motor)

  2. change from FOC to BLDC (same problem at 100A)

  3. use a really small propeller

  4. set the abs over current higher than 150A

Nothing helped. If the motor gets out of sync the abs over current fault is appearing immediately or a bit later depending on the setting for abs over current . The strange thing is that it only will be shown for about a half a second in the RT data page on the app. If I want to print out the faults the VESC does not show these abs over current faults. Is it a bug in the FW?

Anyway, what options do I have to get rid of that nasty problem? I’m so fu***** keen to fly that thing!

Motor cfg

Maybe this could bei an issue?

1 Like

I have kind of same problem with chinese VESC 6. Everytime i do power changes in high power it brings this abs over current faults, and does kind of a reset… Tried to change the above value but no help so far. It seems to be less problem in BLDC mode though…

Very sorry to read that , from my low level on vesc user ,may be you could try :

  • run detection of the motor in the water without prop ( and maybe with it (?) )

  • increases saturation

  • increase frequency to 40 000…

  • check max limit set for: erpm ,power…

  • try as well increasing the ramping time , to slow down things a bit

  • last thing i read : increases battery regeneration

Good luck

Lastest fw update use before no limit ?

1 Like

Good point! Last Thursday I flashed the default fw 3.61. over the weekend they updated the Vesc tool and the firmware to 3.62. So I flashed the 3.62 fw with no hw limits. I will try to flash back the older 3.61 to see If that problem still occurs or if there is something wrong with the new 3.62

I hope you find a way , this is one of the reason i jump directly to the 75/300 ( limit is 420A) but still every time I look at it : i cannot forget its price :sob:

How high have you set abs fault value ?

1 Like

With my 75/300 I lost sync, but increasing the stator saturation compensation fixed it! I think I bumped it up from 1.0 to 1.10 or 1.15

Alright! Good to know that I’m not the only one. At what currents you lost snyc?

If it would help to change the stator saturation compensation this would not explain why the BLDC mode does this cogging issues as well at 100A. :thinking:

I definitely give it a try this week.

1 Like

Well you can have 1 or 2 issues that sum up maybe , since the error isn’t saved but showing off … behavior at the limit, current spikes and synchro …of what I can understand

Its hard to say what currents I was losing sync at, but it made it difficult to get onto the plane so maybe 150a?

BLDC and FOC are very different so I don’t really think that would really matter. Ive never tried BLDC with the new VESCS only FOC.

Does the motor spin well from standstill with no prop and a light load, like with some finger pressure?
It should be fine starting and spinning a hundred rpm or so with low duty and low currents, with a small load from your hand. Does it stutter and cog and have trouble getting going?

Does the FOC sense resistance parameter agree with what the manufacturer says for the phase resistance of the motor?

Can you run the sampling feature and post what the phase voltages looks like while its running at 2-3A?

It’s now working! I needed to set the stator saturation compensation to 15%.
But it always had struggle to start the motor smoothly. Often the motor current raised to 130A without moving the propeller (in air). I fixed that by setting the open loop Hysterese time to 0.1S.

I don’t now the motor resistance data from the manufacturer. But v_s got the same motor and kV and the detected settings are quite similar.

What you mean with sampling feature?

Open loop and ramping time for the remote , yes

Outrunner needs higher frequency , default setting are 30 000 on my vesc , may be 20 000 on the vesc6
I still don’t know if it only sampling as measuring or actually « run » faster , has I understood it only runs haft of this frequency , I tested changement numbers and my motor was running better , changed rpm and amp off load , but I am using a in runner …

Switching should be kept at 20khz to reduce losses. If the motor coggs you should try to lower the resistance by 5%. The Resistance needs to be spot on, and ±5% makes a big difference.
Saturation compensation can be used, but usually it’s not needed.

1 Like

How similar? If the vesc is sensing the resistance wrong, it will have trouble keeping track of where the rotor is and will lose sync, resulting in failed starts or running backwards and shutdowns while running.

Sometimes detect doesnt work. Or you might have a hardware problem. On the left side of the computer vesc tool there is a sampling button. Use that and you can verify that the vesc adcs are working right. All three phases should look very similar.

The Strange thing is: in dutycycle Mode, i can spin Up Quite gentle. In Current mode i have Sometimes trouble to start.
especially when Motor starts in openloop it cogs

I dont have trouble at high rpm or current.

Try a higher openloop rpm, >0.1s timings.

Hi people, I find your disccusion very helpful. Yesterday we tested VESC 6 200A Maytech with 65162SF Maytech 100 Kv. We have driver faults and cut offs at aprox 80 A. I saw that you fixed it with saturation compensation if FOC mode but with outrunner. We were trying with BLDC and cant move it yet in FOC. Maybe you could advice sth? has anyone tried vesc 6 + this motor from Maytech. We assume the problem is high current and low RPM in the begining so no chance to go flying yet. As everybody on this forum says 160 A is needed to pop up from the water. We have good temp cooling the vesc is in the motor under water so no issue with that. The problem is it cuts off.

Is it possible to fix it with changing the parameters?

I believe you can try to reduce frequency to 10mhz with this motor
Max abs amp 20-30higher than max motor amp
You can pop of the water with less than 160a , i need at least with my set up 90A , and 130a is nice but depends on board wing weight…

the issues you describe should not have to do with saturation. The 80100 motor saturates at about 150A (think this was for 120kV motor.)

I guess the problem is VESC detection values are off

What is your kV?
What’s your phase resistance?
Have you confirmed them with your own measurement?