Blue Mind Controller

This controller does not work. It looks nice and can be used as a remote but it gives no data like amps, temperature or rpm. The company does not know why it does not work and they are not willing to give any guarantee or refund so it is like money down the drain.

Das selbe Problem hatte ich auch mit Bluemind - nicht kaufen!

Good to know I am not the only one.
I can see they still sell it on Aliexpress for 430US$.
They say it is not compatible with my new Flipsky 75200 Vesc and they do not know why.
Is there somebody that has got it working?

You’re on the wrong website as you can nearly get 3 items for 430usd on the manufacturer’s alibaba page

But even at 160usd, what is the point buying it if it doesn’t work as promised … ??

You’d better ask to the designer on the original thread

So I did, 24days ago, I think he/she left the forum.
[J qdbluemind


Can you help to set it up. I can run the motor with uart connection however it does not show any data, rpm, voltage, amp. I run another remote the Flipsky Vx2 and this one gives the data. I have tried different settings on BN, PP, ST is 0, TC 1,71. I do not know what it means. I did ever try to switch RX Tx but that did not work at all.
My receiver has an antenna.

I have the same problem. I didn’t see this forum topic in time. Now trying to get a refund from Alibaba.
In addition to not reading VESC data, the buttons are horrible, and the cruise mode is totally insecure. If the person falls and release the control, the efoil will fly by itself until it loses control signal.

Sorry to hear that they did not improve and is still selling, knowing about the problem.
I have seen that they give a 1 year warranty on Aliexpress.
I have talked to them and they say they will come up with a solution but it is a while ago now.