Help with Flipsky 65161 75200 and VX3

Hi Guys,

I built and efoil with the Flipsky water kit including a 6561 motor 75200 waterproof VESC and VX3 remote. The board is a Fliteboard with an adapter plate. Everything is has it should everything connected and the board does not leak. The battery is a 13S8P with 7020 cells. I tried it today I get very little power I could not get out of the water and the remote does not display power. The best I could do is 7 km/h on my knees on the board. Any suggestions what to check what could be wrong.

What are the battery and motor current limits? You need 4kw or so to start then once up on foil much less like 1-1.5kw.

You should be able to get 20kmh aquaplaning then the foil will work.

The battery is 13s8P so full charge 54v 40A/h it’s made of 7020 cells 5 A/h it appears to have plenty of power but the remote does not display the power so I think something is wrong. I programmed it exactly lke in the Flipsky video.

The power will only show when you are in uart mode. The display will say RU in uart mode and current and power will display. However thats not your problem I suspect current limnits are set too low from default wizard setting. I had same 1st run.

1 Like

When you say exactly like video setup, did you connect via usb to the 75200 and use VescTools on a computer??

If you did the wizard sets some initial values in the 75200 One of these is a limit that restricts the power flow to the motor.

I can’t recall where that setting is in VESCTOOLS but if you are patient you should be able to find it.

Lots of posts here about the same issue

You are almost there. You are really going to like the setup once you have a few startup kinks worked out!!

Thanks I found this video it’s very good. I think my power was set too low with the wizard so I did it manually like this guy does. I think that will solve the power issue my amps were probably too low. However I still have the issue of no reading on the VX3 remote. The remote type is PPM in the programming otherwise it won’t connect and the UART tab is set to 11500 baud as he suggest but still no motor data show on the remote. Suggestions are welcomed.

What version of vesctools are you running. Do you have the bluetooth adapter so you can log the data?

It’s the free version 6.02 not sure about the bluetooth adapter. I am using a USB cable to program the VESC but I have a bluetooth module on the VESC for the remote.

Am I suposed to connect the bluetooth module to the PPM port or the UART port. In all the videos I have seen they use the 4 wire PPM port with the cable supplied by Flipsky but in that video above they mention you need UART too to get the data on the remote…

BT to Uart ant pwm to pwm. If you want the vesc telemetry dataon the remote, you need a vesc with a second uart. In vesc tool enable „permanent uart“ for the second uart to work.

Did you buy the Bluetooth module from Flipsky?

If you could post photos of how you currently have things wired up it might help to resolve this.

Yes it’s the Flipsky bluetooth module that came with the water sport kit. Here are 2 pictures. The 3 wires are connected to the PPM port. and the remote works but no power is displayed. The blue wire is not connected they don’t connect it in the Flipsky video. sat_be my VESC has another UART port not used now but there’ no more wires to hook up to.

Never mind. I miss understood you post. I thought you were talking about the BT module not workin.

Thanks for the photo . Picture is worth a thousand words!!

The Bluetooth module connects to the UART2 port #4 using the cable that feeds from that port.

You shouldn’t have anything connected to PPM port #2

I recall having to fiddle with the TX and RX wires to make sure they were connected properly to the correct pins on the Bluetooth module

This article might help IF you have that issue.

You will also have to config “app” in vesctools for UART

When you have it working the VX3 screen will display RU in the upper left corner.

The VX3 receiver is of course connected to COMM port #6

I replaced the short wire antenna with the 1.5m option from Flipsky and ran the wire along the bottom of the battery box to the front where the lid hinges. I wasn’t sure I wouldn’t have signal issues with water over the top of the board etc so that might be something you might consider but if you are already riding it doesn’t appear that you have an issue.

I use an old IPhone connected via the Bluetooth module to run the IOS version of vesctool. This lets me adjust things without carrying around a laptop and also lets me put the phone inside the Flite battery box to create a log file for a session if I want.

You are almost there!!:sunglasses:

Sorry to bother you again thanks for your help so far. I don’t have the Bluetooth module for the phone data it didn’t come with my kit. I only have the small Bluetooth receiver for the remote. it only has a 4 pin connector that terminate into one 3 pin and 1 blue wire with 1 pin. such as in this picture. There is another wire supplied in the kite but it can only connect to port 7 hall sensors and that makes no sense. The 3 pin wire fits perfectly with the PPM port and it works but no power data on the remote. To use port 6 I would have to start cutting wire or get a plugs that fit both port 6 and and the 4 pin port on receiver and make my custom own wire. Maybe I’m missing a special wire that I didn’t get.

Happy to continue to try to help.

I am anything but a wizard when it comes to this stuff and after a LOT of trial and error, reading I ended up with something that works. Flipskys documentation is all about PPM and very little about how to get UART to work. Makes things challenging!!:grinning:

I am using exactly the same components as you so it should work for you to.

It is my understanding that you need to Flipsky Bluetooth module to get the VX3 remote to display all of the data.

This is what I bought - V4 version

My VX3 receiver is connected to COMM port 6

My Bluetooth module is connected to UART2 port 4

There are several cables in the VX3 kit. The photo shows the receiver, PPM wire you are using now and the correct wire to use when connecting to the UART2 port. Look carefully at the wire colours to get RX and TX oriented correctly.

I do NOT have anything connected to PPM port 2

The following is a screen shot of what I received from Flipsky support regarding UART

Hope this helps.

1 Like

Thanks I did not receive the cable that you are using with the VX3 receiver module and I don’t have the Bluetooth module for the phone either. I have been talking to the Flipsky support. I don’t mind buying the other module if I need it. I’ll try to get them to ship me the missing cable at the same time. I’ll see what Flipsky say.

All the VX3 cables and the receiver are packaged in a small plastic bag inside the zippered case. Odd that you didn’t get them.

Again not positive you “need” the Bluetooth to get the VX3 to connect UART as I connected the receiver to COMM but I find being able to log data and make changes to limit settings etc using a phone (Android or Apple) is very useful.

You review the log using a computer running VESCTOOLS “Log analysis”. Shows a GPS track of your session along with lot of detailed info. As the log data file is CSV you can also open it in a spreadsheet program and sort for min-max values etc.

It occurred to me that you might also want to review what your limits are for V.
The first limit reduces but lets you limp home. The second limit cuts power completely to protect battery. Adjusting those values within safe range lets you extend ride time.

Success at last! I searched my workshop with a fine tooth comb I found the bag with these 2 wires. It had fallen behind the work bench. I had to run the remote wizard in NRF mode for the remote to work but now it looks like everything is working. Looks like I get data on the remote but it’s hard to tell I don’t want to run the motor inside too long. It’s getting very cold here in Ottawa but hopefully I can try this beast on the water on a warmer day in my drysuit. Thanks for all your help. I will purchase the phone module but it looks like it’s easy to get but it sounds like I don’t need it for the remote to work.

Congrats!! :grinning::grinning:
This is what it should look like

When I’m foiling I often look at speed and battery level. I find the other data a bit challenging to focus on while I’m moving. The temp is important to look at while things are new, but now that I have moved to Flite adapter, mast - passive cooling it has never gotten above 32C.

A word of caution is to point out the the VX3 has cruise control. I accidentally turned it on once and luckily didn’t fall off as the board would have travelled a long distance before stopping. No way to disable it either!!

Drysuit - short session is still possible. I was out on the weekend in similar weather/water conditions. Stay close to shore as mostly all the boaters have stopped for the season