Connecting Maytech remote to 75200 - need assistance please!

Hi guys,

VESC (75200), motor (65161, 120KV) and remote (Maytech MTSKR1905WF) have finally arrived (waiting for equipment is so hard!) and I have connected them all. I am using a 16s LFP battery setup - that’s 48v-58v. :electric_plug:

I have updated the firmware, disabled phase filters (75_300_R2, VESC_default_no_hw_limits, okay?) run motor detection (large outrunner), it squeaks a little, then runs smoothly (FOC), I had to invers rotation so the prop turns the right way. I also set number of motor poles to 6 because I remember it somehow (?) and because it has 3 cables and 3 is not a number to choose from in setup. :wink: I guess this is right?

You can see I have connected the BT thingy in the only slot that has enough pins, so I could do all the things above. Am I right that this actually is only needed for setup via mobile phone and I can just as well do setup by connected my windows via USB cable? Anyway, iphone app seemed to work good. :phone:

Now I need to connect the Maytech BT thing for the remote to work. And I have NO idea what to do. Can anyone please advise? What cables belong to where? Thank you! :pray:

So I have made one more step just to run into more trouble …
I have the remote receiver connected to PWM_T / 5v / GND. Additionally, I have bound BAT to one of the power lines. Now I can not only connect the remote but see the status of my battery at the tiny display of the remote. :slight_smile:
But when I pull the trigger, the motor just squeaks a little. I have run multiple detection functions, FOC detection, have not really changed anything of these 1000 values one can edit - because I just don’t know what all these parameters mean.
Shame on me - I must admit, I don’t even know the very basic things: what kind of motor is this? Large inrunner? Number of poles? What is Max Power Loss? Openloop ERPM? Do I have to change any of these settings?
When I set the remote to PPM and Control Type to whatever, the motor makes knocking and squeking noises, but does not turn. One time it wouldn’t stop even if I let loose. I had to disconnect everything to stop it. What the hell? Nothing got warmer than my hands though, so I believe I haven’t killed anything (yet).
I found it very annoying and frustrating getting this to work. I have spent hours and nothing seems to make sense. Please, could somebody give some hints? Thank you.

You might find some info here:

Interesting explanation for the motor choice at 0:11 (source: the comment area)

Thank you, tried it allover again. Again and again. For hours! Back to start: firmware upload, disable filter, motor detect (using medium inrunner). Checked all values that make sense to me (current, voltage, battery settings). Disconnected the control to not let it interfere somehow. Even played a little with observer gain. No luck. Not spinning. Hit the buttons FWD / REV to get it to spin. Ran the experiments. Nothing. It just makes funny noises, which are not funny anymore. Whatever I do the stupid motor just keeps squeaking and sometimes knocking. It is so freaking annoying.

I am so sick of this chinese cheap (and it wasn’t cheap! and had to wait 4 darn weeks for it!) piece of crap. I have opened a dispute on Banggood hoping to get my money back. Advise to everyone: don’t even think about buying ANY of these “cheap” chinese VESC copies. Go get the original TRAMPA even if it is almost twice as expensive (well, I don’t have one yet, but I assume they actually do what they are supposed to).

Have you tried FW 5.1? Works well for many setups. If it still doesn‘t work, you might got one with wrong resistors, search the forum.

Thanks for staying with me. Many setups. Sure? I have read about the versions with wrong resistors, doubt it for my 75200 because that was last year I believe, mine arrived last week. Will take a look but need to reread how to to this …

Okay, I have downloaded old software, uploaded old firmware (5.1). The VESC tool looks a bit different.
I have again reset everything. Then set everything correctly to my knowledge. Motor detection breaks with the message “Flux linkage detection failed”, looked it up at VESC forums, it seems “because of Battery Cutout voltage set above the voltage being used”. Definitely not the case. Cut off settings are at 44v start/40v end. Set it to hilarious 24v / 20v, made no difference. Needless to say, the battery pack is close to full, I have measured 54v at VESC input. :electric_plug:

Different approach, more trouble. No idea what more to try.

Holy moly!

While looking for a solution for the “flux” message, someone wrote in a ESK8-forum three years ago to check the motor cables. Don’t say … could it be …? I removed the plugs and connected the cables directly - guess what - it now works! :grinning: :roll_eyes:

I was using solar cable plugs (the strongest MC4 I could find) to waterproof connect motor cables to the ESC. They actually connect well (measured them) but they simply don’t seem to work with high current. Hard lesson. Took me three days and countless hours …

I need to look for an alternative. Best would be one 150A three-pin waterproof plug, but haven’t had any luck finding one yet …

1 Like

Congratulations! Take a look at the Amphenol Surlok series. The common 5.7mm size is rated at 120A if I remember correctly. That would be enough for the motor, since you rarely get that much motor amps, and the load is split over three cables.

Hey Juha, thank you, I will use Surlok plugs to connect the battery, but was looking for something “lighter” for the motor cables. Will give newer solar plugs another try and see.

One more thing I have noticed: when I click on FWD/REV (to check if direction is right), the spinning always has some rough sluggish start moment. Hard to spot on video:

Any idea?

Try to set motor break current to a small value (instead of 0), i.e. -3A, it helped for a smooth start in my setup.

For the connectors, AS150/XT150 in waterproof cable connector glands work well, see here: DIY - budget - high amp waterproof connectors - #27 by michion

I have seen these but I thought they are “cable connectors” only … I now see it is modified to be plugged & unplugged. Cool idea!

Will try the brake settings, thank you!

@sat_be brake settings smoothed it a little (set to -5), not completely, but I’ll stick with it. It only worked using the newer firmware again, not with the old, btw.

I am almost there, but now having a hard time calibrating the throttle. I switched on RT/APP for setting the 0% / 50% and 100% pulselength. Saved it to the VESC of course. Also tried the Setup-Input Wizard, which does the same. The values look very good actually. But: it gets to full throttle once I reach the “Input Deadband”. An input of 10-11% (having deadband set to 10%) gets it turning from 0-100%. I already feel embarrassed asking questions here, especially about things that seem to be easy … but I just can’t get it working right. :pensive:

If you use „current control“ this is normal behavior without load, see here: VESC Tool thread - how to program - #98 by sat_be

1 Like

love smileys