ESC Flycolor X Cross HV3 settings on BlHeli 32

Problem all sorted with the X Cross, it was a setup issue with the VX3, appreciate the help, thank you gentlemen.

I’ve actually also gone with Current Protection set to Off as suggested by Jesserosco. The VX3 has H, M, L setting to reduce power and I’ve found that has worked well in the past with non current limited, powerful, escs.

2 Likes

I finally have my motor esc and controller all assembled and am using the telemetry wire off my 120Amp X-Cross to display the amps. The value reported correlates extremely well with the DC amps I measure via my multimeter attached to the battery leads. + or - about 2 amps.

4 Likes

What did you do to read telemetry data? Arduino?

2 Likes

I’m hoping some electrical engineers in the group can help me.

I’ve been using my 160A X-cross for about 8 weeks now and it’s been working really well.

For some reason yesterday, I plugged a fully charged pack in just to check my receiver was working and the second I plugged in, the ESC sparked and then completely fizzled up in smoke.

Upon closer inspection it looks like the main failure point is the small row of smd capacitors closest to the heatsink. I can’t understand what has happened because I am using an anti spark XT90 and am always super careful with water and making sure there is no water ingress or droplets anywhere near the esc.

Has anybody else had their ESC go up in smoke just from plugging in a battery?
I was using this system 2 days ago with absolutely no issues at all.

These are my BlHeli settings that have been working great this far.

Any help appreciated. I am about to replace with the same ESC but don’t want to have heart failure from plugging in a battery.

Yes, it is a xaio esp32 s3 which I program using the arduino IDE.

The code I posted above in this thread. It should work with minor tweaks on any arduino compatible board that has an extra serial UART. Alternatively, one could probably use the SoftSerial arduino library which can mimic a UART.

2 Likes

Man that sucks. Makes me nervous about using mine.

Only thing I can think is maybe your phase wires were touching or damaged after your last session and when you plugged in it tried to play the startup music and fried?

Dunno though. Crossing my fingers that this is explainable

On that note of phase wires - can I program this esc without connecting to the motor?

Yes, I have done that. I avoid giving any throttle, but that is probably fine as the FETs are essentially just turning on and off without the circuit being closed, so should be harmless.

1 Like